Error 0x80070079: The semaphore timeout period has expired


MioNet worked for me but I had to upgrade and now WD2GO no longer works.

First time after upgrading to WD2GO the file transfer worked. Now it times out and I get the error:

Error 0x80070079: The semaphore timeout period has expired

What is weird is the progress bar goes by pretty quick up to 100% then it never completes and will eventuall time out.

I checked the router setting, firewall etc but all checks out. I still have a lot of disk space on mybooklive 2TB so not sure what is causing this error.

Does anybody know how to fix this?

Thanks in advance.

What OS are you on?

Have you tried this on another machine (say with Windows 7 or Mac OS X)?

At home where the NAS is located I have a Windows 7 Home Premium 64-bit. From my apartment downtown I use a desktop PC with Windows 7 Ultimate 64-bit. The first time I upgrade to WD2GO it worked fine. There hasn’t been any changes to the NAS or anything in my network. Now if I try to send some videos 775MB to 1.2 GB size it starts ok then the progress  windows just stays on 99% but never compeletes. After that I get the semaphore error. I checked my share, port forwwarding on the router, firewall and antivirus but they are not blocking NAS/My Book Live as far as I can tell. My current workaround is to use a teamviewer and FTP to the NAS drive and that works perfectly. So I suspect something is not working right on WD2GO. I wish I can bring back Mionet. Anyaway any help and suggestions you can provide will be really appreciated.

Thanks WDTony!


That was the next question I was going to ask you. I talked to the developers and they said that this error can occur in windows when transfering large files over WebDAV. This is a windows related issue - I just did a quick google search on this and can see a number of threads on this issue :