Erased drive and now I can't use it within smartware or windows (SOLVED!)

I have a My Book Elite and was having trouble with a few files and folders I couldn’t delete. I backed up my external drive and used the WD smartware erase function on it. I let it do its thing and afterwards I ran into some problems.

It won’t show up in My Computer anymore. It shows the drive  when i go to safely remove connected hardware via the taskbar but nowhere else. The only thing i can interact with is the virtual drive. Smartware acts even weirder. If i run smartware it shows up in the home tab but with the message “No writable WD SmartWare partition found” and I can’t interact with the drive in any way, only safely remove it. If i run the VCD manager I can hide/show the virtual CD drive and the WD Quick View shows the drive as connected, with the default name, and as unlocked but I still can’t do a **bleep** thing with it.

what is going on? how do i fix this? I’ve already tried uninstalling and reinstalling smartware and it didn’t help

EDIT: Solved it by manually formatting via disk management. Guide is found here:

Good stuff dude 

now post again and mark this as solved