Enter Network Password?

I did a system only factory restore to see if I could get rid of the problems I was having and for a while everything (mostly) was fine, now I’m being asked to enter a network password in explorer for any share I’ve set to private.

None of the passwords associated with mycloud account work neither does my pc log-on and it’s not the home group password.

Only if I set all the shares to public can I access them directly from Explorer.

Untitled2.jpg Untitled3.jpg Untitled4.jpg

Hello, try using WD discovery to map the shares. Check the link below for the steps. 

Mapping a drive letter on a WD Network hard drive using WD Discovery 

Nope, can only map shares that are public, still asked to enter network password.

thanks anyway.

In the My Cloud UI, you should see something like this:

MC_Users.jpg

On Windows, the Username wiil be the same as it appears here in the My Cloud UI.  If you did not turn on the Password in the UI, then in Windows leave it blank, if you have it on in the UI then this will be the password you need to enter in Windows.

Also, make sure that if the folder is private that you have set the correct access permissions (in Share Access or under the Shares tab) for the User you are logging on as.

No, I’ve got the same username and passwords across the board win & mycloud, they don’t work.

I don’t know why I’m even asked for a password, page 58 of the manual- Untitled.jpg

And Knowledge base ID5681 relates to win XP I’m using 7HP

@Tenlegs

Did you resolve your problem? I’m having the exact same problems:

No problems accessing public shares, but for some reason I’m asked for credentials for my private shares (yes, same user/pw as my Win7 account). No combo is working. I can map the share via WD Discovery, however I cannot access the share.

To make things “funny”, I also have an older WD MyBookLive, with the same settings (user and pw on both WD and Win). There I have no problems connecting private shares.

Of course I could go with public shares, however I’d like to have documents and what’s not somewhat protected under password. Then I could use public share with truecrypt … but that’s just way to much work-around — I should be able to access my private shares:-)

Kind regards

JonasJ

You cannot access PRIVATE shares after accessing public shares first.   It’s a limitation of Windows.

Clear all connections on your PC:

  - Open a CMD window as administrator.

  - Execute the command

net use * /delete

Then try to access your private share.

4 Likes

Hi ToniPh12345,

Thanks for your swift reply. But I’m sorry to say it didn’t work out.

I did the “remove all” thing, rebooted the computer - still no access, removed all “old” (ie from the old wd MyBookLive), rebooted the computer and the MyCloud - Still no access:-(

I did use the WD tool “discovery”, which sees both my NAS’s as well as my shared media (from MyCloud), but I’m every time asked for credentials to log into x.x.x.104 (the IP address of my MyCloud). And no credentials work.

It is a bit odd, that I’m asked for credentials for the IP address rather than the cloud-name … and also a wee bit strange that although I’ve asked the MyCloud to be part of the “NONAME” workgroup (not my usual “ATHOME” workgroup) it doesn’t show up in win explorer.

I’m thinking it may be some sort of WDfluenza and I might be better off with a system restore?

Cheers J/

Did you try not entering a password at all and leaving the “password” field empty?

1 Like

If it wants credentials, it will ask for them regardless of how you mount it (by name or IP).

What happens if you try to mount it via the command line?

Like:

net use * \wdmycloud\sharename

2 Likes

Thanks Tony!!!

This was my problem, they should add documentation for this since users and shares are public by default >.< 

Thank you both for your time and fast (!) answers.

@ RealAct: Yes. I did try leave both user and password [empty] and a real user and password [empty] --> that didn’t work out :slight_smile:

@ Tony: This is kind of odd. I tried your “net use etc” and (ohh it seems like its is case sensitive) … With my “user-share” (the one default created per user) it came up with “OK command executed”. Nothing else. It was not in explorer. However I did manually connect to it via explorer (add network storage etc). That went well.

Inspired by my luck (and your advice) I tried my other share (the “common share for all users”, not public but a mediashare created so all my users can access the same media-files) … no luck. Both on command-line and the long way via Explorer “add …”

Both ways I get the (dreaded?) please sign in to the domain.

  WDcredentials.jpg

The “Domæne” is of course domain, and that (REMOTE) is my home workgroup, I do not have a domain-server.

The MyCloud is on another workgroup (“NONAME”). It doesn’t make any difference if I set MyCloud to “Remote”.

I cannot help but thinking that it is a windows “feature” …

Cheers J/

I should have said it a different way.

You cannot access Private shares after accessing Public shares, nor can you access two different private shares that have different credentials.

So unless your “Common Share” has the same user / password combination allowed for it as your “user-share,” you won’t be able to access both.

Hello all. I just set up my 3TB My Cloud a few moments ago and already ran into this issue when creating seperate shares for my family members.

If I am understanding this correctly there is no way to access the Public share and then to access my own private share on my Windows machine without using a cmd prompt? Is this correct?

This is very annoying if correct. It should just prompt for the correct username and password assigned in the My Cloud UI.

I can however access all shares regardless of public or private that I have access to through the Windows WD My Cloud app correct? Can I also pull files from the Windows My Cloud App to my local desktop?

Thanks for the help.

leenypost wrote:

If I am understanding this correctly there is no way to access the Public share and then to access my own private share on my Windows machine without using a cmd prompt? Is this correct?

No.   If you access the PUBLIC share first, just provide the credentials for the PRIVATE share.  Then there won’t be a problem.

leenypost wrote:

This is very annoying if correct. It should just prompt for the correct username and password assigned in the My Cloud UI.

That’s what it’s doing.  However, it’s MICROSOFT that prohibits the use of different credentials for different shares on the same NAS.   No other operating system has such a limitation.

Thank you Tony.

For some reason the credentials I set up for the private shares do not work when I enter them. Also, my windows login credentials do not work either so I am not sure what I should be entering.

For now I just made all shares public.

Hi guys,

Thank you for your time and effort!

Sorry for the delay (New years sort of got in the way:-)

@Tony - Sorry if i’m slow, but i do not understand. I can create shares (not users) in MyCloud, but i cannot access any of them unless they belong to “my user”?

At current i have a share (the default share for my user) - that i can access. I’ve also created a share (“stand alone” so to speak), I’ve granted my user full access to that share, and i’ve granted an other user full access to that share as well.

If I understand you correct, due to windows limitations I cannot create a share that I can share with other users at my network? Even if those users also are users a MyCloud (with identical MyCloud/Win credentials)?

Pictures are sometimes better:-) This is my (common) share:

And this is my user:

In windows, I’ll never get access to jkMedia?

No, that should work fine.  You can access as many shares as you want as long as they’re all assigned to the same user.

1 Like

Hi Tony,

Yes, that’s what I thought. Now here’s a truly weird story:

I cannot map MyMedia (as I’ve deleted the previous common shared folder and created a brand new one - because I thought there might be some sort of bad vibe with the last name:-) through WD Discover:

access code.jpg

And I’ve grated my user full rights:

However I can access my share via “browse my shares” in WD Discover, and then link the share to my computer:

I’ve just added a file (yes, it’s Bob The Builder:-) to see if I could write to it. In a moment I’ll see if it works as media server. It better!

So problem sort of solved, I’m just not sure why and how :smiley:

Cheers

// Jonas

I had a similar problem with credentials where it was asking for them everytime I logged into the computer.

Background:

It was after I employed Vic Laurie’s excellent article ( http://www.techsupportalert.com/content/how-move-windows-7-personal-folders-my-documents-another-drive.htm) on symbolic links.  Essentially I was making it so that each user’s My Document, My Pictures, My Videos, Desktop, etc. would always reside on the NAS.  I did this to make it easy on the kids, because it seems so many programs utilized these folders these days as default data locations and I wanted their default activities to go right into the NAS for centralization reasons.  When the machine was booting up and logging into a User’s profile, an error would occur while retrieving the desktop during log in.  It’s the same error you’ve described and had me scratching my head.  It wasn’t just a mapped drive thing and I was using full UNC paths for the symbolic links.

I overcame the error message by going into Windows 7’s “Credential Manager” and adding a Windows Credential for the specificed share while logged into the User’s profile.  No more error.  In Credential Manager, the network address pointed to the user’s share ( e.g. \MYCLOUD\Nathan ) and the User Name and Password were for the WD MyCloud share (not the Windows account).  I practically NEVER have to use Credential Manager in any of the other business-domain/Active Directory IT work I do, so it didn’t come to mind at all.

Maybe this solution will help you too.

-John