Encryption option is not available through the Dashboard

Hello!

Opposite to the user manual I don’t see the encryption option when I create volumes on the WD My Cloud EX2 Ultra. But I have this available through SSH.

So when I login with PUTTY I have tried the following:

umount /dev/md1
cryptsetup -y -v luksFormat /dev/md1
cryptsetup luksOpen /dev/md1 mycrypt
mkfs.ext4 /dev/mapper/mycrypt
mount /dev/mapper/mycrypt /mnt/HD/HD_a2

All that worked fine and my WD EX2 Ultra showed 4Tb free space of just encrypted RAID 1 in the dashboard.

However after a reboot the dashboard says there are no set RAID Volumes. Of course, because they need to be decrypted and mounted! But when I login to SSH, I see no md1 anymore. So I have to re-create the RAID again and decrypt it:

mdadm --create /dev/md1 --level=1 --raid-devices=2 --metadata=1.0 /dev/sda2 /dev/sdb2
cryptsetup luksOpen /dev/md1 mycrypt
mount /dev/mapper/mycrypt /mnt/HD/HD_a2

My purpose is that a newbie can manage all this from the dashboard without using PUTTY each time after the boot. Is this possible?