Encrypted virtual volume

Hi all,

does anyone know if it is possible, with the WD My Cloud device, to setup an encrypted virtual volume/drive?

I mean, an image file, which can be mounted from Linux as a file system and which is encrypted on the flight.

I’ve tried these instructions: http://encryptionhowto.sourceforge.net/Encryption-HOWTO-4.html, but I couldn’t even mount a non-encrypted device:

WDMyCloud:~/tmp# losetup /dev/loop0 $(pwd)/crypto.img
/dev/loop0: No such device or address

The same with the -e option (tried serpent, twofish, blowfish, aes). It seems that the loop module isn’t available in this device’s kernel (‘modprobe loop’ fails and a ‘find’ under /lib/modules can’t find anything like *loop*).

Thanks in advance for any help.

Hi, this is currently not supported, maybe some of the other users can share some advice with you. 

1 Like

Thanks Ichigo. I’ve also tried to see if I can recomile and reinstall a new kernel for this device, but it seems the default Debian configuration doesn’t point at a complete Debian package source. Also, I guess it’s better to wait that the device guarantee expires, before tweaking things this way…