Enabled UPNP, wd2go.com and WD2go on ipad and iphone not working

Hi friends

Anyone encountered this problem that when you enable the UPNP and the system shown “Connected. Port forwarding connection established.” The WD2go.com and WD2go on Iphone and Ipad not working.

However when I disabled UPNP and dependent on the relay connection, both my WD2go.com and WD2go on Iphone and Ipad are functioning good.

What is the case for it?

Hi, have you tried using a manual IP?


I have set the MBL to and when I key in my external ip address on browser, it point to externalipaddress/UI that means the UPNP is pointed correctly.

I tried the previous method which one of the user mention, disable the remote access, restart and enabled it again. However I browse the wd2go.com,  it stil point to


xxxxxx is my drive id.

It can’t point to my external ip addrress even though I have restarted the system.

FYI: I have set the default setting for the MBL. The remote port forward was set to “automatically” using UPNP. Therefore my port forward is 80/443. At the router (pace model) side, it displayed correctly.