Enable webdav and directory listing for 1 share

I’m trying to enable webdav for one of my shares in following way, but it´s not going well.

1, Enable directory listing by adding the following line to /usr/local/apache2/conf/httpd.conf:

<Directory "/usr/local/apache2_dav/webdav/Pictures"> Options +Indexes </Directory>

2, I try to access the share from a browser like this:

3, I log in with one of the users that have access to the /Pictures/ share

4, I got:
"Not Found
The requested URL /Pictures/ was not found on this server.

I have port forwarding 8080 ok and webdav enabled both under Settings->Network and under the share itself.

What am I doing wrong?

You shouldn’t need to add any lines to config files via ssh, you can enable WebDAV from the configuration page for the individual shares in the dashboard (in the shares tab, select the share you want to enable it on and then in the config section that appears on the lower-right hand part of the screen, WebDAV is one of the options).

You will also need to globally enable WebDAV elsewhere in the dashboard. I think it’s under settings > Network, but don’t take that as gospel as I’m doing that from memory.

Also for some browsers (e.g. IE) you can’t access WebDAV shares that way without additional software or add-ons. For Windows I use CarotDav and Android I use WebDAV Nav Lite, but there are many other options. I think there is also an add-on you can install into some versions of Windows to allow direct access through Windows Explorer (as a web folder) but I’ve never been able to get that to work.