Elephant Drive blaming WD for not working

So my cloud backups to Elephant Drive have been sporadic at best. Will be fine just long enough to gain my trust… then it fails and I go 2 weeks with no files backed up to the cloud. I have been going back and forth with Elephant drive for weeks and they are simply blaming WD’s poor integration of ED’s system or updates. Have a ticket open with both places now and waiting for WD to start blaming ED for the problem… I just need it to work so we don’t lose data… i don’t care whose fault it is really.

Any others have the same problem?

So for now it seems I will have to logon in and out of the Elephant drive service on the EX4 daily or even several times a day to maintain my cloud backups.

ED’s service will not tell you if it’s working or not and WD’s system just randomly stops ED’s service from working.

And they both seem to simply blame the other for it. Nice.

I have not seen many posts mentioning similar situations with the Elephant Drive app, making be think it could very well be a server issue on their end unless it’s a device (Hardware) issue.

Did you try a factory reset? Are you using the latest firmware release? Have you tried using a different router?

I have not jumped through the reset recently.

The firmware is currently 2.11.164 , So I think I am up to date.

Elephant drive clearly told me the issues were on WD for not updating their end. See the reply here-

"Mat Muller (Help Desk)
Jul 12, 10:41 AM PDT

Hello Jesse,

Thanks for your reply.

I have been in contact with our engineering team in regards to your issue. Unfortunately, it seems that the version on ElephantDrive for WD NAS devices is a bit outdated and contains some issues where ElephantDrive may need to be restarted from time to time.

We are working closely with Western Digital to deploy the latest version to WD NAS users. Unfortunately the process is taking longer than expected. For now my suggestion is to install the ElephantDrive application on a desktop device and use it to backup your NAS as a mapped network drive.

Please let me know if you need further instructions on how to do that.

Sincerely,
Mat Muller.
Technical Specialist."

I guess the issue was escalated but still no word on it. I did get an email that said it would close the case if I did not reply… and I have replied and sent logs etc…

For now I have to log into the ED cloud backup multiple times a day to be sure it is still processing or running.

Hoping the resolution to this does not involved being told it is ED’s fault…

So I received an email from support asking for a date and time they could call me to troubleshoot issue… They seem to have blown me off. the date was today and the time was 10:00 AZ time. so 1.5 hours ago.

Is that common?

I tell them in my reply with date and time that MY firmware was updated and that trying to blame the company that is blaming them was not really an option… Soooo we shall see I guess.

Problem is still there- Cloud backups just randomly stop running and I have to log out and in what seems like several times a day to keep them running.

Any recommendations for dealing with support when they don’t call or reply to emails?

This is getting rather ridiculous.

JD

Update- I did finally get an email reply last week- Was told they are escalating the issue and reviewing my submitted log data-

So far today it seems like the issue has been better- it has actually been running for a few hours without having to log out and in of ED on the WD interface. Fingers crossed it maintains that.

I am requesting that you please escalate this issue to another level.

When I come in after a weekend and the back up has not been running and I log out and back into the Elephant drive service on your device it begins backing up/processing within 10-15 seconds. So it sat there all weekend doing nothing because i was not sitting there to log in and out every time it stops running.

My employer is getting very tired of paying me to try and get this problem solved. I am getting tired of waiting for weeks to get any sorts of replies or updates.

This system needs to function without me here to baby sit it 24 hours a day. This problem is endangering our company data set and could be a very costly issue. A previous ransome-ware infection is what led to us selecting an EX4 and part of that selection was it’s ability to backup/sync to a cloud storage service. It did that pretty well for some time but is not failing to operate in the way that it should.

Please solve this problem or we may be forced to find another solution at great expense to us in time and funds.

The problem boiled down is that the EX4 will not seem to keep running the ElephantDrive cloud backup for any certain period of time. I open the ED web interface and check the current backups report and it says that it is ‘monitoring’ the backups. It is set to continuous so that it should be updating the cloud instantly/constantly.

Once I log out and then back into the ED service on the EX4- the ED service appears to start processing files within 10-15 seconds. Then it might keep running for 5 minutes or 5 hours. No way to really tell unless I check the reports constantly. Then logout/in every time I find it not running.

ED says it’s WD’s fault etc… Is there a script or an app that I could create/run that just logs me out and in of the service every hour or at a set interval? This is really getting ridiculous.And I am getting no ‘support’ from ‘support’ at this point.

Finally got through on a call yesterday- was promised a call within 24-48 hours.

No replies to emails- maybe a call some day- is this par for the course?

I ma having to sit here and log in and out of the ED service on the EX4 every few minutes as it stops backing up. Just crazy that this is going on over 4 weeks since the first post/report/request. And this is after ED spent a week or so on it as well.

THe employer is getting really tired of seeing ‘dealing with server and cloud issues’ on my time card. 8^|

Well I was promised a call in 24/48 hours as of 11:00 am on the 14th… So we are now at almost at 72 hours and no call or even an email.

Next up Twitter… In between logging in and out of the ED backups on the EX4…

I really expected more from WD than this.

OK- Never got a phone call so I called- on hold for 45 minutes and got to a person. Was told that the case had been escalated to level 3 and they think it was an issue with to many processes overwhelming it or latency on the end of our ISP.

I keep an eye on our ISP and it’s always been solid. 85ms ping, it changes of course but very stable.

I have asked for any reports or better explanations of the technical issues so that I can try and deal with it. Turns out I have to be de-escalated to level 2 to get a phone call and they are very hesitant to actually email me any sort of report etc.

Really trying to be reasonable but this is getting over the top.

Hello jd_drafter,

We are sorry to hear you are having issues with ElephantDrive and apologize for our delayed response. (We are working to get alerted when new threads/responses related to ElephantDrive are posted in the WD Community.) Please understand we are not blaming Western Digital for your experience and issues with ElephantDrive. We are happy to answer any questions you may have and also, if you are interested, we can help you install a newer version of ElephantDrive which might resolve your issues.

Thanks for the reply- I have gone through the support process with ED previously- Prior to this comment/post. Escalations and such yielded that the WD EX4 and it’s firmware were out of date and not working with ED as it should.

I am happy to work with any solution you may have in order to keep my data safe.

I was getting some place with WD or so I thought but the solution there ended up being told to upgrade to a new device as the EX4 was getting outdated. The technician has not replied to any emails since that conversation.

So I am open to solutions.

Hi jd_drafter,

Please email us directly at "support@elephantdrive.com" and be sure to reference your username in this forum (jd_drafter). Once you have a ticket in our support system, we can help you install a recent ElephantDrive build which should resolve all issues. Looking forward to hearing from you soon!

It is done- fingers crossed!