Elements SE disc letter not assigned


I just got an Elements SE 1 TB HD yesterday for Christmas and when I first plugged it in, it seemed to work fine and was recognized by the computer.  I tried to do a backup and it failed because of a Windows 7 error.  After some trials with WIndows, I unplugged the drive and plugged it back in.  On doing this, the drive started making clicking sounds and took a while to be found as a USB device and to be installed, but did install.  On opening my computer, it failed to show my Elements drive listed as a drive.  It was listed under devices and was under the device manager.  I just have no way to access the drive.

I have tried to restart the computer, reformat the drive and have had no luck.  I am starting to think that it is a malfunction with the drive, but I am not sure.  Any suggestions would be appreciated. Thank you.

You can try another USB cable and see how it goes

the clicking on portable drives normally means lack of power or drive failure