Easy method to downgrade to previous version of the firmware

Hopping on this thread as I have been trying with lots of fail to get LMS on my Mycloud2. It’s turning into a waste of money…or rather a chucked WD NAS and a saved 2TB disk :slight_smile: Synology is looking like a good option right now.

I successfully downgraded the firmware…except now the dashboard is completely blank. I can still see the shares from the App, but cannot access the dashboard… help! :slight_smile:

Same thing happened to me (dashboard is blank).  Did you figure out a solution?  Thanks!

You should be able to solve this with a system reset.

  1. Unplug the power cord

  2. Unplug the network cable.

  3. Wait a few minutes

4. Press and hold the reset button

5. Insert the power cord while still holding the reset button.

  1. Hold reset for 40 seconds.

  2. Connect the network cable 

I registered on this site to say thanks PVS0705 for your clear instructions.

I followed your instructions to the letter and the downgrade worked for me.

Issues before downgrade:

  • Settings/Utilities/SystemDiagmostics/QuickTest got stuck at 90%

  • Not seeing Blue LED light at all. I see yellow flash then solid on boot up. Then light goes off. But system is still accessible.

Configuration before downgrade:

  • WD MyCloud 2TB with Firmware

  • I backed up and removed all data from drive

  • I did a FULL factory restore (Settings/Utilities/System Factory Restore/Full Restore)

  • Network Mode set to Static

  • Turned off DLNA Media Server and iTunes

  • I plugged device power directly into wall

Results after downgrade:

  • Settings/Utilities/SystemDiagmostics/Quick Test completed successfully!

  • Now running and waiting for completion of Full Test

  • Did not fix LED issue described above.

  • Home/Firmware is showing orange triagle alert (due to old version presumably)

  • Changing setting in dashboard is clearly faster. For example if I select Settings/Network/SSH/ON the blue slider switch changes state noticibly faster that when using the newest firmware.

  • Have not tested speed accessing files through Explorer yet… but I’m assuming due to snappy responsivness from withing Dashboard, accessing files from Exporer will be faster too.

Conclusion (so far):

  • Downgrade does increase performace

  • I will need to continue to search for solution for blue LED light not showing on otherwise functioning device.

1 Like

As a follow up to my previous message:

  • Full Test completed successfully

  • Home/Firmware is showing green check mark even though I am running this older firmware.

 (not sure why it was displaying an orange triangle for a day)

Also note to others who tried to upgrade firmware and get the “cant upgrade because not enough space” error.

Before I did the downgrade I was getting this issue too.

I did a Full Restore (after backing up all my data) and it resolved the issue.

I was able to update the firmware… which caused other issues, so I followed the downgrade instructions in this thread.

Now, I just need to figure out why I have no blue LED light on the front of unit.

Im starting to think its the actual light… I get only yellow when rebooting and initializing, then it turns off. but appears to be functioning ok in every other way… strange.

1 Like

 Thanks to  PVS0705 I was able to downgrade from version 4.  On one note…I had to use Terminal on my MAC to log-in and change the default password, then I was able to FileZilla into the unit and change the Version file.


I’m sorry to say. But how many others will join me on the old 3x firmware

Want to use this solution as in first post but problem with the latest version of Winscp , keeps crashing, been to their forum and it is a problem. Anybody got an old version they could email to Me ?

this is the version I just used.  Im on windows 10.  Its version 5.7.5  https://www.dropbox.com/s/d4f1iav90pycs5b/winscp575setup.exe?dl=0

This isn’t exactly a response to this issue but it was the only thing that ended up working for me.  I had a My Cloud 3TB and any time I connected my My Book to it, the My Cloud would drop off the network and be invisible to Windows Explorer and the Dashboard.  Nothing we tried (Level 2 support) got close to fixing the problem so I could run backups.

I then moved to a 6TB My Cloud Mirror (RAID 1), and I was able to get all but one of the shares to backup.  Eventually, the My Cloud Mirror started crashing off the network and I was unable to backup any of the shares.  I was able to provide a lot of data to WD engineering and it came down to the firmware, CPU, memory, and the number of files that were in the shares being backed up.  Now, I don’t think I am really that unusual as I only had about 1TB of data with some video and picture files and Office documents. But there was something there that was choking the system as the logs showed time out issues.

I then moved to the EX2100 and all the problems went away.  It is a slick unit with a faster processor and more memory.  It doesn’t hickup when backing up all the shares and response time to Dashboard is pretty much instantaneous.  Now, someone looking for a modestly priced cloud device certainly isn’t going to jump to the EX2100, but if you are looking at a business solution, do look at the EX2100.

Kudos to the level 2 tech that worked with me over the months. He never gave up and was always prompt with his communications, even if he didn’t have any new news.

1 Like

Hi Guys. This thread is aging but if anyone knowledgeable is still around…I’m running the latest v04.04.00-308. Just bought mycloud a few weeks ago. I was having some issues with videos freezing for a few seconds but after disabling ipv6, turning off dlna, twonky, disabling .wdmc files and deleting them I’ve noticed an improvement. Of course there was’t much testing. It could’ve been network related or some other anomaly. My question is do I have any reason to revert back to version 3? Have any of the issues been resolved?
Really I’m looking for informed guidance. Is it advisable to install OMV? I tinker but definitely not an expert. I’d like to be able to run mysql and maybe nzbget but I have them on my mac so it’s not a deal breaker. Thanks.

I’m just in the same situation but for other reasons. Just bought the 2TB MyCloud and saw the problems of v4 firmware and other possibilities of v3. Wondered if this method is still valid for v04.04.00-308 downgrade to v03.04.01-230


Yes this method still works. I used it to downgrade from to 3.04. Remember to use the 40 second reset after downgrading. This will delete your shares and your users but it will clear out any problem residues especially the SSH lockout.


Thanks @Ralphael and @PVS0705. All worked like a charm. First reboot displayed an empty dashboard and after 40s reset all went OK. The process of registering got some error msg which I think it is due to the first time I registered the device. Otherwise all looks good.

Now… on business :slight_smile: :smile:

I’m glad this still works.

Might as well post the following firmware links to this thread. Somewhere someone wanted links to past firmware but cannot find that thread in a search. In rolling back the firmware to find one that will work with my external 1T USB drives I wound up compiling the following firmware link list from various other threads. Obviously some firmware versions are missing.

Firmware Release 04.04.03-113: http://download.wdc.com/nas/sq-040403-113-20160510.zip
Firmware Release 04.04.02-105: http://download.wdc.com/nas/sq-040402-105-20160111.zip
Firmware Version 04.04.01-112: http://download.wdc.com/nas/sq-040401-112-20151013.deb.zip
Firmware Version 04.04.00-308: http://download.wdc.com/nas/sq-040400-308-20150924.deb.zip
Firmware Version 04.04.00-307: http://download.wdc.com/nas/sq-040400-307-20150921.deb
Firmware Version 04.04.00-303: http://download.wdc.com/nas/sq-040400-303-20150902.deb.zip
Firmware Version 04.01.04-422: http://download.wdc.com/nas/sq-040104-422-20150423.deb.zip
Firmware Version 04.01.03-421: http://download.wdc.com/nas/sq-040103-421-20150217.deb.zip
Firmware Version 04.01.02-417: http://download.wdc.com/nas/sq-040102-417-20141211.deb.zip
Firmware Version 04.01.01-413: http://download.wdc.com/nas/sq-040101-413-20141106.deb.zip
Firmware Version 04.01.00-408: http://download.wdc.com/nas/sq-040100-408-20141010.deb.zip
Firmware Version 04.00.01-623: http://download.wdc.com/nas/sq-040001-623-20140904.deb.zip
Firmware Version 04.00.00-607: http://download.wdc.com/nas/sq-040000-607-20140630.deb.zip
Firmware Version 03.04.01-230: http://download.wdc.com/nas/sq-030401-230-20140415.deb.zip
Firmware Version 03.04.01-219: http://download.wdc.com/nas/sq-030401-219-20140218.zip
Firmware Version 03.03.02-165: http://download.wdc.com/nas/WDMyCloud-030302-165.zip
Firmware Version 03.03.01-156: http://download.wdc.com/nas/WDMyCloud-030301-156.zip
Firmware Version 03.01.04-139: http://download.wdc.com/nas/WDMyCloud-030104-139-20131028.zip
Firmware Version 03.01.03-127:
Firmware Version 03.01.02-125:
Firmware Version 03.00.03-413 – Initial Release:

One can view the entire release history in the current firmware readme file: http://support.wdc.com/download/notes/WD_My_Cloud_Firmware_Release_Notes_04.04.02-105.pdf

Post updated with new links

1 Like

That is good to know this downgrade still works (BTW–I’m on the absolute latest of of a few days ago- v04.04.01-112). But, I’m wondering if it’s still necessary to downgrade? I’ve disabled a bunch of services including wdmc server and I disabled sleep. The effect was it runs faster and an issue I was having with some videos freezing appears to have stopped. But having no comparison I can’t say if the latest is better or worse than v3.
Is there anyone that can speak to performance increase or other benefits like I’d like to use mysql and it’s be awesome if I could get sickbeard to run on this. I just have concerns about the cpu and how these services will impact speed. Thanks.

hi Guys,very good Info

but here my Problem to fix this …wdcloud 4TB do not boot to BLUE

Hi Support
Problem is that my WD 4TB cloud will not boot properly.
Cloud ran for approximately 1 year without any problems to access through software and browser there she

was always

a bit too slow and if you changed anything it took to talk up to 3-6 minutes to the change

had taken over.
Now is no longer possible to access, often it remains just loading the operating system hang, LED

Yellow, sodas just not “booted” pilaris BLUE LED.
After reset 4sec. she was sometimes sporadic “to see” but when copying data they broke easily

middle from (error 64) and was again not too sehen.Obwohl the Cloud BLUE!
The tips on troubleshooting, Lankabel reset etc. brought no improvement.
When you restart attempts
Off-web-30sec. wait-back power, and then wait whether to blue LED (if it did not work)
-Reset At power-on and wait until “Boot” successfully
nothing positive to put on new message LED YELLOW FLASHING (supposedly network error)
I’ve even used another network LAN cable
did not help either!
The fact is:
-Lankabelverbindungen Are ALL ok
-Power Supply the cloud is ok, tested PSU with USB3HD.
-Cloud Shows sporadically after “restart” 2 messages 1.permanent Yellow Sytemboot 2.Gelb-blinkt-

Lankabeldefekt, but changes to permanent yellow after a few minutes again,
up to sporadic blue-permanently-ready (after about 1 hour to boot)
-If BLUE sporadically connect Workplace away are 2 folders / links times available times not,

1 times without 2 times 2 times 1 + 2 but with access (copy / save) Demolition 1 + 2 off!
Toll the now vorraussichtlich my over 2TB data have Datentot found because the cloud
any defect has. (NOT REPRESENT as possible Abruch)
-on Werkseinstellng reseten not run because I still want my data if possible !!!
I suspect that the firmware or board has an error (firmware update automatically! Error?)
or even the HD defect, since (if they boot times) but will appear in Windows after kutzem Access-

Aborts and connection is gone although BLUE!
Have now the forum found something: Downgrade the firmware to help!

Can it really not be. New firmware makes these problems?
And now to the small end consumer the judge?
Toll when the cloud allegedly is blue, but you can not even access it to try it.
!!! FAIL WD !!!

Bin for suggestions and help, if possible, be grateful.
Before I bring you back to the dealer and ask for my money back!
(with all the collected information)

on Time:I try 40sec. reset

Have Kontakt with Support…this will help…
-have done Factory reset (40sec.by Power ON)
-Fact:Cloud no more work right !
-Boot 1 from 8 good “Blue”
-when “Blue” kopie only 1 Folder…then fail Conecting
-do not work by Init. in Bowser…fail by language selection

I hope Support Help me

I have downgraded but now i cant use the remote access feature, anyone else having this problem?

The Remote Access features (Mycloud.com portal, My Cloud apps / Desktop) only work officially with the latest OS3 firmware. The reason why was explained in your other thread…