Easy method to downgrade to previous version of the firmware

Hi Guys. This thread is aging but if anyone knowledgeable is still around…I’m running the latest v04.04.00-308. Just bought mycloud a few weeks ago. I was having some issues with videos freezing for a few seconds but after disabling ipv6, turning off dlna, twonky, disabling .wdmc files and deleting them I’ve noticed an improvement. Of course there was’t much testing. It could’ve been network related or some other anomaly. My question is do I have any reason to revert back to version 3? Have any of the issues been resolved?
Really I’m looking for informed guidance. Is it advisable to install OMV? I tinker but definitely not an expert. I’d like to be able to run mysql and maybe nzbget but I have them on my mac so it’s not a deal breaker. Thanks.

I’m just in the same situation but for other reasons. Just bought the 2TB MyCloud and saw the problems of v4 firmware and other possibilities of v3. Wondered if this method is still valid for v04.04.00-308 downgrade to v03.04.01-230

Thanks!

Yes this method still works. I used it to downgrade from 4.00.04.00-308 to 3.04. Remember to use the 40 second reset after downgrading. This will delete your shares and your users but it will clear out any problem residues especially the SSH lockout.

Done!

Thanks @Ralphael and @PVS0705. All worked like a charm. First reboot displayed an empty dashboard and after 40s reset all went OK. The process of registering got some error msg which I think it is due to the first time I registered the device. Otherwise all looks good.

Now… on business :slight_smile: :smile:

I’m glad this still works.

Might as well post the following firmware links to this thread. Somewhere someone wanted links to past firmware but cannot find that thread in a search. In rolling back the firmware to find one that will work with my external 1T USB drives I wound up compiling the following firmware link list from various other threads. Obviously some firmware versions are missing.

Firmware Release 04.04.03-113: http://download.wdc.com/nas/sq-040403-113-20160510.zip
Firmware Release 04.04.02-105: http://download.wdc.com/nas/sq-040402-105-20160111.zip
Firmware Version 04.04.01-112: http://download.wdc.com/nas/sq-040401-112-20151013.deb.zip
Firmware Version 04.04.00-308: http://download.wdc.com/nas/sq-040400-308-20150924.deb.zip
Firmware Version 04.04.00-307: http://download.wdc.com/nas/sq-040400-307-20150921.deb
Firmware Version 04.04.00-303: http://download.wdc.com/nas/sq-040400-303-20150902.deb.zip
Firmware Version 04.01.04-422: http://download.wdc.com/nas/sq-040104-422-20150423.deb.zip
Firmware Version 04.01.03-421: http://download.wdc.com/nas/sq-040103-421-20150217.deb.zip
Firmware Version 04.01.02-417: http://download.wdc.com/nas/sq-040102-417-20141211.deb.zip
Firmware Version 04.01.01-413: http://download.wdc.com/nas/sq-040101-413-20141106.deb.zip
Firmware Version 04.01.00-408: http://download.wdc.com/nas/sq-040100-408-20141010.deb.zip
Firmware Version 04.00.01-623: http://download.wdc.com/nas/sq-040001-623-20140904.deb.zip
Firmware Version 04.00.00-607: http://download.wdc.com/nas/sq-040000-607-20140630.deb.zip
Firmware Version 03.04.01-230: http://download.wdc.com/nas/sq-030401-230-20140415.deb.zip
Firmware Version 03.04.01-219: http://download.wdc.com/nas/sq-030401-219-20140218.zip
Firmware Version 03.03.02-165: http://download.wdc.com/nas/WDMyCloud-030302-165.zip
Firmware Version 03.03.01-156: http://download.wdc.com/nas/WDMyCloud-030301-156.zip
Firmware Version 03.01.04-139: http://download.wdc.com/nas/WDMyCloud-030104-139-20131028.zip
Firmware Version 03.01.03-127:
Firmware Version 03.01.02-125:
Firmware Version 03.00.03-413 – Initial Release:

One can view the entire release history in the current firmware readme file: http://support.wdc.com/download/notes/WD_My_Cloud_Firmware_Release_Notes_04.04.02-105.pdf

Post updated with new links

1 Like

That is good to know this downgrade still works (BTW–I’m on the absolute latest of of a few days ago- v04.04.01-112). But, I’m wondering if it’s still necessary to downgrade? I’ve disabled a bunch of services including wdmc server and I disabled sleep. The effect was it runs faster and an issue I was having with some videos freezing appears to have stopped. But having no comparison I can’t say if the latest is better or worse than v3.
Is there anyone that can speak to performance increase or other benefits like I’d like to use mysql and it’s be awesome if I could get sickbeard to run on this. I just have concerns about the cpu and how these services will impact speed. Thanks.

hi Guys,very good Info

but here my Problem to fix this …wdcloud 4TB do not boot to BLUE

Hi Support
,
Problem is that my WD 4TB cloud will not boot properly.
NO RED LED !!!
,
Cloud ran for approximately 1 year without any problems to access through software and browser there she

was always

a bit too slow and if you changed anything it took to talk up to 3-6 minutes to the change

had taken over.
,
Now is no longer possible to access, often it remains just loading the operating system hang, LED

Yellow, sodas just not “booted” pilaris BLUE LED.
,
After reset 4sec. she was sometimes sporadic “to see” but when copying data they broke easily

middle from (error 64) and was again not too sehen.Obwohl the Cloud BLUE!
,
The tips on troubleshooting, Lankabel reset etc. brought no improvement.
,
When you restart attempts
Off-web-30sec. wait-back power, and then wait whether to blue LED (if it did not work)
-Reset At power-on and wait until “Boot” successfully
nothing positive to put on new message LED YELLOW FLASHING (supposedly network error)
I’ve even used another network LAN cable
“RESTART”
did not help either!
,
The fact is:
-Lankabelverbindungen Are ALL ok
-Power Supply the cloud is ok, tested PSU with USB3HD.
-Cloud Shows sporadically after “restart” 2 messages 1.permanent Yellow Sytemboot 2.Gelb-blinkt-

Lankabeldefekt, but changes to permanent yellow after a few minutes again,
up to sporadic blue-permanently-ready (after about 1 hour to boot)
,
-If BLUE sporadically connect Workplace away are 2 folders / links times available times not,

1 times without 2 times 2 times 1 + 2 but with access (copy / save) Demolition 1 + 2 off!
,
Toll the now vorraussichtlich my over 2TB data have Datentot found because the cloud
any defect has. (NOT REPRESENT as possible Abruch)
-on Werkseinstellng reseten not run because I still want my data if possible !!!
,
I suspect that the firmware or board has an error (firmware update automatically! Error?)
or even the HD defect, since (if they boot times) but will appear in Windows after kutzem Access-

Aborts and connection is gone although BLUE!
,
Have now the forum found something: Downgrade the firmware to help!

,
Can it really not be. New firmware makes these problems?
And now to the small end consumer the judge?
Toll when the cloud allegedly is blue, but you can not even access it to try it.
!!! FAIL WD !!!

Bin for suggestions and help, if possible, be grateful.
Before I bring you back to the dealer and ask for my money back!
(with all the collected information)

on Time:I try 40sec. reset

update:
Have Kontakt with Support…this will help…
-have done Factory reset (40sec.by Power ON)
-Fact:Cloud no more work right !
-Boot 1 from 8 good “Blue”
-when “Blue” kopie only 1 Folder…then fail Conecting
-do not work by Init. in Bowser…fail by language selection

I hope Support Help me
by

I have downgraded but now i cant use the remote access feature, anyone else having this problem?

The Remote Access features (Mycloud.com portal, My Cloud apps / Desktop) only work officially with the latest OS3 firmware. The reason why was explained in your other thread…

https://community.wd.com/t/cant-use-wd-my-cloud-cloud-access-feature-after-firmware-downgrade/147269

I cant believe no one else is mentioning this, anyone have a workaround?/

People have mention it in the past (do a forum search) but as has explained in those threads as well as this one and your previous one, downgrading the firmware potentally breaks the various official WD supported methods of remote access. That is one of the trade offs one makes when downgrading the My Cloud firmware.

Also explained in various other threads there are various ways to roll your own remote access. These range from enabling FTP via the My Cloud Dashboard (and activating router port forwarding of port 21 to the my Cloud) to setting up a VPN server on one’s local network to bypass the need for using the MyCloud.com web portal.

Ah! FTP! great idea thank you

Many thanks for this. After downgrading firmware everything works so much better. The downgrade was pretty painful though. In the end what got it working was a 40 second reset during power-on. I read about this in another forum post. In other words, pull power, push reset and insert power and hold reset for 40 seconds. This got the dashboard working again (initially it didn’t work after the firmware downgrade).

The older firmware works so much better!

Hi, I can not downgrade from version 2.xx to 4.xx because
when editing the version file and change it to 03.04.01-219,
when restarting it is changed back to ersion 2.xx and wanting
update firmware download error, help please.

You cannot downgrade the firmware on a second gen (v2.x) My Cloud to the first gen (v3.x/v4.x) My Cloud. Different hardware and file structure between the two versions.

Nor can one “upgrade” the firmware on first gen v4.x My cloud to the second gen v2.x My Cloud firmware.

I followed instructions in the first post and was successful in restoring my MyCloud. Note that I used putty not WinSCP (which would not connect to the MyCloud for me).

There is definitely a problem with the version 4 firmware that WD should fix (are you guys listening?). My MyCloud worked fine for several years and then lost its connection to my LAN. I downgraded the firmware from version 4 to version 3 and my MyCloud now works great again.

My approach was as follows:

Download the following firmware version and unzip the .deb file (File sq-030401-230-20140415.deb.zip) http://download.wdc.com/nas/sq-030401-230-20140415.deb.zip1.6k

I used putty (not WinSCP) to logon to the MyCloud linux console (username: root, password: welc0me).
Then the following linux commands:

cd \etc
ls
nano version

In the “version” file, edit the version name to 03.04.01-219 and save the file (This version is older that the 03.04.01-230 that I downloaded and intended to apply. This fools the MyCloud into thinking that is has firmware version 03.04.01-219 and it will therefore let you upgrade to version 03.04.01-230 using the MyCloud console).

exit (to logout)

Reboot the MyCloud.

Next, logon to the MyCloud console, and select Settings | Firmware | select from file. Note that auto update is disabled by default. Do not try to turn it on/off, or the firmware update function will not work (you only get one chance to change the firmware after each reboot). Also, if the MyCloud complains that there is not enough space, wait for the MyCloud to finish its startup scan which can take about 10 minutes. Once the MyCloud shows space available on the homepage, the Firmware update will work.

Enjoy your newly repaired MyCloud. smile:

Downgrade can be done but the problem persists. In addition, share folders are disappeared in web UI. Intermittent connection issue still appears in my case unlike yours.

So, I restored back to latest firmware which is WDMyCloud v04.05.00-320 : Core F/W.

  1. Restart WDMyCloud
  2. Let it stable for 10-12 hours. I leave it for a day. (Content scanning is taking place when your reboot it - I guess)
  3. Enable SSH through UI
  4. Warning: I use WDMYCloud only for storage. I use SSH/FTP for file transfer as it can resume transfer as PC resumes from sleep.

Login to SSH and reboot again after running the following commands:

killall -9 winbindd

killall -9 rcpbind

/etc/init.d/netatalk stop

update-rc.d netatalk disable

/etc/init.d/restsdk-serverd stop

update-rc.d restsdk-serverd disable

/etc/init.d/samba stop

update-rc.d samba disable

/etc/init.d/nfs-kernel-server stop

/etc/init.d/nfs-common stop

update-rc.d nfs-kernel-server disable

update-rc.d nfs-common disable

/etc/init.d/upnp_nas stop

update-rc.d upnp_nas disable

/etc/init.d/mDNSResponder stop

update-rc.dmDNSResponder disable

/etc/init.d/wdphotodbmergerd stop

/etc/init.d/wdmcserverd stop

/etc/init.d/mdadm stop

update-rc.d mdadm disable

/etc/init.d/rpcbind stop

update-rc.d rpcbind disable

update-rc.d ssh enable

update-rc.d vsftpd enable

update-rc.d apache2 enable

1 Like

Can u please show me where this etc folder on the right pane.

These instructions for MyCloud 1st generation (Gen 1, FW v04.xx)
You have MyCloud Home - it is completely different device based on Android.
So, there is no “Easy” method for downgrade. Only upload full disk image vith previous firmware.
Maybe its possible to throw device into “recovery boot”, but idk how…