e2fsprogs: PreDepends: e2fslibs issue

I get an error when I try to use apt-get to install some packages:

You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
e2fsprogs: PreDepends: e2fslibs (= 1.41.12-2) but 1.42.2-2 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I tried a[t-get -f install but that does give another message:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
initscripts sysvinit-utils
The following packages will be REMOVED:
e2fsprogs ramlog
The following packages will be upgraded:
initscripts sysvinit-utils
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
2 upgraded, 0 newly installed, 2 to remove and 251 not upgraded.
Need to get 190kB of archives.
After this operation, 2404kB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'

How can I resolve the e2fsprogs issue ?

somehow i had to do the update of the mybooklive firmware again, i did the update from the ui when i got the nas drive and that seemed to have worked oke. The ui said it was updated to version 53 but the apt-cache stated it was still at version 007. running the update from ssh did install the 53 version the second time oke and updated also the e2f packages. so I got apt-get working …

You are aware, if I read the initial post right, that apt-get is removing system programs that W.D. have put in the MBL on purpose?

No it should not remove programs, I did not accept the solution apt-get was giving me. The e2fsprogs and libs do not sound like optional packages to me.

Somehow the initial update of the firmware right after I plugged in the mybooklive the first time went wrong. (The ui said it went oki, but apparently it did not for some reason) 

So I did the firmware update again from ssh and the update went oke and apt-get no longer gives issues with the e2fslibs.

By any chance did you update firmware to “02.11.09-053 (4/23/12)” before this issue started to happen?