E/: is not accessible Access Denied

Alright I have scoured forums and I have not really seen anything exactly like my problem. The problem is this, I plug my WD Passport (320 GB) into my PC, it shows up under “My Computer” but when I try to access it it tells me Windows can not access this drive. I Windows 7 and I have even tried to be brave (or stupid) and do the “Scan drive and fix Errors” option when that pops up, even though someone told me it reformats the drive. Still nothing, tells me the same thing. “this operation cannot be performed because Windows can not access Drive E”. I have all my work on it from my Associates program and some personal stuff on it. I even ran my virus scan on the drive, and I can see it scanning all the files/folders. So I know data is still on it. Just why can’t Windows access it. I tried messing with permissions and everything, nothing will let me in. Any ideas??

by the way, this has nothing to do with the post, but i made a typo on my user name, it is originally supposed to be BigSal30, not NigSal30. Don’t want anyone to think it was derogotory or degrading.

I just recently bought my very first WD drive (My Passport). It’s been working like a charm backing up my files on 2 of my PCs…that is, until I tried to access the folder belonging to my 1st PC using my 2nd PC. I now get the error message you posted.

By any chance, has anybody responded to you with some tips/help?

I am having the same issue. Hoping someone can help us out.

It might be a sharing/permission thing. Go into drive properties and change settings there. You may want to do a search of how to it can get complicated from Vista onward.