DX4k in weird state

This is my first time here, please be gentle. I’ll try to recount all of the wacky stuff I’ve seen…

We had a big power outage over the last weekend, and my server room UPS ended up running out of power and everything shut down. When I brought the DX4000 back online on Monday, I had a hard time getting it to boot. Initially, it did a “Loading OS” then back to initializing loop. I tried to do a recover using a 32GB USB stick, but it showed “Bad Storage” and a red light indicated that bay 3 was bad. I pulled the drive and tried rebooting, but I got a “Storage 9x(something)” error, at which point I plugged the drive back into bay 3, rebooted, and… it booted into the OS! It showed bay 3 was bad, still.

After doing some research, it looked like I could update my software to the latest version, apply the Sentinel Drive Enabler patch and just replace bay 3 with a new HDD of the same capacity. Unfortunately, the software update failed and the machine rebooted itself. I WAS able to apply the Drive Enabler, but I’m still on the old software version.

Now I’m back in Windows, and from the dashboard, I can see that there’s a warning that drive 3 has failed, however, I have NO lights on the front panel. The display shows the machine name and IP, Number of drives: 0, and Available capacity: 6TB when I scroll with the arrows. In the Dashboard, I can’t see the Intel RapidStorage tab at all, and I can’t find a GUI for the array. I’m afraid to just pull the drive and replace it, I don’t want to cause data corruption.

At this point, my goal is to be able to view the array from within the Intel GUI and verify that drive 3 is, indeed, bad. Anybody have any idea how I can get the GUI back (or what happened to it)?

you can try this

Aug '17

Here’s a pleasant surprise:

Open a command prompt.
CD C:\Program Files\Windows Server\Bin\Addins\Primary
copy rst_addin.bak Intel.RST.HSBS.Config.addin

Open Server Manager => Configuration => Services
Find "Intel® Rapid Storage Technology Monitoring Service. Right-click - Properties and set to Automatic and OK. Then start the service.

Now open the dashboard. You’ve got a new icon!

1 Like

If you have any data you need you should copy it to another drive

Yeah, I backup all my data from the NAS to a cloud service, so that’s secure, at least.

Updates from last night:
Ran the software update again, this time it succeeded. I had lights on the front again, and it was once again reporting that HDD 3 was bad. Well, since I had the new software, and I applied the drive enabler, I decided to plug in one of the fancy new drives I had bought for it. I pulled drive 3, put the new drive in, and… The machine rebooted itself. That ■■■■■, I was hoping for a rebuild.

OS load took forever, but when it finished, it started the rebuild! This was all last night. When I came in this morning, all 4 drive lights are lit, LCD displays server name, IP, number of drives (4) and available capacity (6TB). Everything is fixed? Not so fast…

Despite the LCD showing nothing about rebuild, the machine is sluggish (I mean, more so than usual). I never got an e-mail about the rebuild being complete, so I check the dashboard (did I mention that it’s SLLLLLOOOOOOWWW) and under “monitor”, it reports that it’s still rebuilding. Since I have no way to check the % now, I’ll assume that’s why it’s so sluggish. For reference, I have 4 3TB HDD’s in a RAID 5, so I assumed it’d take some time to rebuild, but it’s been over 14 hours now. Anybody know how long I should expect this to take?

After adding the Rapid Storage Monitor, I checked it and I see that the rebuild is only 78% complete. Well, that explains the sluggishness! Guess I’ll just wait for the ol’ girl to finish the rebuild. Thanks for the info on re-adding the service, Gramps, that helps a lot!