DX4000 - Server backup via its USB port

Does anyone know if attaching a WD My Book to the DX4000 allows a full backup of the NAS including software, etc.?

The first issue is if your DX has a capacity over 2tb you need a 3rd party to back it up.
If you are less than 2tb the problem is finding drives compatible with Windows Server Backup
The problem with 3rd party solutions is they do not offer a headless restore
https://social.technet.microsoft.com/wiki/contents/articles/1780.windows-small-business-server-external-backup-drives-compatibility-list.aspx

Gramps - do you know what happens when you plug an 8tb WD My Book into the USB on the NAS? Does it become an extension of the NAS that can be addressed by a PC?

Gramps - I’m getting 4 - 4TB drives (WD4000F9MZ-76NVPL0) to replace my 4-3TB drives. How can I replace the existing drives without having to do a restore or reconfigure? Can I get the additional 4TB from the new drives without restoring? Thanks!!!

Your best hope for the external is it will see it as a drive letter. You could then copy your data to it.

I do not know of a way to upgrade. Just take out the old drives and keep them in order in case it fails. Put the new drives in and do a rebuild from bare metal and start over.

Adding to see if @DTMtech has any wonderful insights on building a box with non supported drives. The new firmware/iso may do it, I just have not done it myself.

My suggestion would be to get a Thecus WIndows 4 or 5 bay from ebay Then you could just keep both

Is it possible to replace one drive at a time - and allow it to rebuild the array each time?

yes if you have the drive enabler installed but because it is raid 5 they will only use the same 3tb and not the 4.

Now I have no clue if you had all four 4tb drives running at 3tb if you could install the Intel rst tools and expand the array. Possible…

If you just want new drives, sure, if you want expanded capacity …

The model numbers I noted above are what Level 3 tech support @ WD said will work - supposedly without drive enabler. They are listed on the compatible drive list from WD (answer ID 9443). I don’t mind losing the extra 1tb per drive.

Then what did they say do?
If you do not mind losing the space plug one in (after you get a copy of your data)

Replace the drives one by one AFTER backing up the data. I assume the raid will rebuild after each drive replacement :frowning:

That is how it works with compatible drives. If you look in the dashboard WD what version firmwaredo you have? I hae not looked up your drives

My current software is 1.7.3.13 I tried installing the latest version 1.7.6.21 - downloaded the zip file to my PC and moved it to a NAS share - ran it and it said it installed and then it said the software update failed. After that it isn’t showing the drive lights and the power light is red. It rebuilt its’ RAID 5 array and still no lights. Also under the RST tab it shows 2 of the drives as “external”. Now I’m getting confused. The firmware on the drives is 01.01D01

In RST under manage disk there is a selection to “activate port LED” which it won’t let me select / change. This all started with the drive in bay 3 failing - now RST says its’ status is “normal”…

I only trued rst once and it broke things. But that was a very long time ago.

Sorry, I have just not spent anytime with anything other than original supported configs.

The firmware should upgrade in a standard config. That said this is getting so old and certificates expire. I really do not think WD cares