DX4000 Not Accepting New Harddrive - "Incompatible"

Hello, I have a degraded drive. I ordered https://www.cdwg.com/shop/products/WD-Red-Pro-NAS-Hard-Drive-WD2002FFSX-hard-drive-2-TB-SATA-6Gb-s/4229730.aspx?pfm=ord and installed. Database must have been out of date as it says it’s incompatible. My firmware is 1.5.8.31. When I download the file 1.7.6.21 (https://support.wdc.com/knowledgebase/answer.aspx?ID=16630&s=) it installs, closes Dashboard, and I wait 10 minutes, then restart machine. Firmware still says the same thing.

So I tried to install Drive Enabler, installed successfully, then machine restarts, still says the drive is incompatible. So I’m at a loss at this point. I called WD Support, they said someone would have to call me back, never received a call. Hoping someone here can help.

Thanks!
Richard

not sure
you are doing the firmware by pointing to the zip file, not a folder with it extracted?

Correct. It starts updating, then closes Dashboard.

Been a long time but I thought it showed some progress. Put the zip file on the d: drive somewhere and just let it go overnight. Obviously it should not take all night but perhaps it is taking longer than 10 mins

tomorrow look and see if there is anything in c:\wd\logs maybe a hidden folder

fwiw this is what I get for the hash file for the zip file
6BAB9AD2F6FF044547213FB965216C0B

I put it on the d drive and let it go, didn’t touch it, came today, and restarted the machine, logged back into Dashboard, and it’s still the same. I opened the log folder, and sorted by date… there are only 2 files recently updated.

PreUpdate.txt has only “Sun 01/21/2018 22:17:23.83 UN-Hide c:\WD folder”
iSCSIlog.txt is the other file, and it’s huge, but don’t think that’s what I am looking for, is it?

Any other ideas? Still no call back from WD.

not yet.
My first thought is it may be to big of a firmware jump but that is just a wag
Obviously you need to make a copy of any data you need
You could play with wayback and try working your way up with firmware’s.

You can start over (wipe and reload) but I “think” you need at least 2 good drives on the list. I may be wrong though. I think @DTMtech has spent some time with other drives.

But something is “funky” if the drive enabler does not function either. You do not have any AV installed on the server do you?

https://web.archive.org/web/20150227171233/http://support.wdc.com:80/product/download.asp?groupid=1601&sid=166&lang=en

I might be wrong but the drive enabler is only compatible with the latest version of the firmware (1.7.6.21). Which is the original drive and which is the new "incompatible drive? Your setup is with 2 or 4 hard disks?

It might be the case your firmware version is too old and you should try to upgrade to an intermin version first (e.g. 1.6…), then try to update to 1.7.6.21. Of course I would advise to make a backup ASAP.

The good news is that this is just a backup drive itself. So any data loss is fine. I’ll see if I can find an interim firmware version. Any links you have for former versions is appreciated - can’t seem to find it. Thanks!

I have a DX4000 w/ 4 - 3TB drives (12TB tl) - OS: 1.7.3.13, Windows Storage Server 2008 R2 that had a drive failure. The original drives were WD3009FYPX-09AAMB0 (3TB).

The WD30EFRX (3TB) red drive did not work - the drive that did work was WD4000F9MZ-76NVPL0 (a 4TB gold drive) that was recognized with no problem. Didn’t require “drive enabler” or anything else.

The volume is still updating / rebuilding after the swap - will update when done…

PS: I had the same problem trying to update the OS and drive enabler wouldn’t work either!

Problem solved! Turns out I needed to run all the Windows Updates (not sure specifically which one allowed it) before I could use Drive Enabler. Flyguy711 is right - Red Drives are not approved - but as far as I can tell, from what WD said (they finally called me) it doesn’t cause problems. They didn’t say that directly of course, but once Drive Enabler was installed, it started rebuilding after a restart of the system. WD said that the drives that came with the Sentinel DX4000 are no longer compatible with most of the drives currently on the market. At any rate, rebuild success!

Who woulda thunk, Windows updates… I guess we just take for granted all updates are installed.
Thanks for reporting your find and progress !

I made a fresh install of a DX4000 starting from RED WD drives (but of course I had to manually update the HD list on the USB sticks and virtual DVD). Regardless of this to avoid issues I installed the drive enabler after the recovery was completed

Thanks for the update - could you post the whitelist file?

you can edit it yourself and upload it to USB again. I did it and everything worked correctly for me.