DX4000 Image recovery does not work (authentication error at boot)

I came across the need to recover a HP Spectre laptop from a DX4000 image however I got stuck almost immediately. I created the USB boot but the W10 HP laptop reports the following error: “Selected boot image did not Authenticate”. I know about similar problems with recovery sw like Acronis but everything was solved using newer Acronis versions. This is something I cannot expect on DX 4000 Windows 2008 storage server. I remember this has something to do with UEFI secure boot however I wonder whether there is a clean way to overcome this issue. thanks

can you not disable the need to authenticate in BIOS?

It is possible to disable secure boot, I tried but still was not sufficient and a different error was report. Looking at some documents I found I should probley also enable the option for legacy boot as well. I am only a little bit scared because I would not like that in this way I could completely break the Windows 10 installation, I hoped to find some cleaner way to perform the recovery without modifying the BIOS

If you think it through I think disabling is the only way. I mean I think it is doing what it is supposed to. Not boot from just any old thumb/disc/OS

But I do not think legacy would work because you need uEFI assuming it was set to uEFI, you had a uEFI partition on your hard drive.

Your F2 boot menu (however you get to it) you should (may say) the thumb twice. First may say Kingston Traveler (whatever) and below it should say uEFI thumb. You need to select uEFI thumb

You must have the uEFI hotfix applied if it was backing it up. The restore thumb has to be created after the hotfix. As in if you have an old thumb that would not work either.

I typed a lot without asking, What was the new error :slight_smile:

PS: It may be easier for you to attach the disk to another PC that is running and do the restore from it. This way you bypass the boot issues. I don’t have a thumb or install handy but the file is something like restoreclient.exe You just dbl click that on the working PC and it will launch the wizard. You just have to be sure and manually select the proper computer to restore and the match the proper partitions from the backup to the correct disc.

This says WHS 2011 but it is the same for the DX4000

Hi Gramps,

I cannot attach the drive to another workstation as it is embedded in the laptop (HP Spectre), of course it might be feasible but I will not for sure try that with the unit still under warranty, worst case I will go through a complete recovery using the embedded partition (■■■■!). Indeed if I run the application on the USB stick directly on another workstation it works exactly as in your picture.

I confirm the DX4000 has been updated with the UEFI hotfix (otherwise W8/10 backup would not have worked)

The error I get after disabiling securboot is shown in this picture…

I think that error is the pc trying to boot from the hard disc. You could remove the thumb and see if you get the same error and or the thumb is not booting properly. I mean it is booting bios not uEFI

Was the other pc uEFI? Is your thumb formatted fat or ntfs? If Ntfs I think you need to copy all the files to a folder and format the fat32 and copy the files back. Be sure and select uEFI thumb in the boot choices
https://technet.microsoft.com/en-us/library/jj200124(v=ws.11).aspx?f=255&MSPPError=-2147217396

The thumb has been created by DX4000, it is FAT32. I managed to avoid the above error setting legacy enabled (and of course secureboot disabled as well), however after “windows is loading files”… “starting windows” I then get another error: RestoreCDinit.exe - application error: exception unknown software exception (0xc00000025) at position 0xFF07B477.

I also tried to run restoreclient.exe from the HP Spectre itself, but the windows application stops with errors either using automatic recover or custom recovery (I guess it cannot recover an image on the same workstation where the restore application is running from W10 itself). It looks I am stuck unless there is any other clever way to solve the issue. I am actually a little bit concerned because for easily accessible hard drives I can use the trick you suggested to connect the HD directly to another client, but for laptops where the hard drive is not easily dismountable the Windows 2008 backup becomes useless

regards

Davide

I think I remember that error and it was like it just did it sometimes as in the first time but not the next, or you just go back in the wizard and hit next. Or do you not get far enough to retry next?

That said I don’t think you want to enable legacy boot. for giggles would you format the thumb with diskpart as in the article above format=fat32

and post a picture of the boot choices menu F2, F12 whatever The thumb drive is normally listed twice (without legacy mode enabled)

There is no way to avoid the error. The thumb is formatted fat32. The options I get are the following:

if I select the USB hard drive I get the error of the previous picture (windows failed to start). If I select Boot from EFI I have several options…

first one is the USB, second is the HD, if I select USB…

selecting bootmgr.efi we are back at the windows failed to start picture

I dunno. you can look at this one about the boot.wim. The lappy just may be too new/advanced to work :frowning:
left out the link…
http://forum.wegotserved.com/index.php?/topic/25782-client-restore-crashes/

I am uploading a boot.wim from 2012R2 to dropbox. Perhaps it will be there tomorrow and I can share it. No clue if it will work, but worth a try I suppose

Try it and see. Can’t hurt

Hi Gramps,

Replacing W2008 boot.wim with W2012 did help but only with secureboot OFF and legacy enabled (otherwise I get the usual “Windows failed to start”). In fact with W2012 boot.wim I did not get the original error of RestoreCDInit.exe and it is possible to play with the recovery options. So an advance has been made because even with legacy enabled the W2008 thumb stops with RestoreCDinit.exe - application error: exception unknown software exception (0xc00000025) at position 0xFF07B477.

However unless I made something wrong no images are recognized from the DX4000 after connecting with the DX4000 probably because the W2012 image is not meant to be used with W2008 storage server (actually I think W2012 boot.wim is looking for some network shared folder as there are other options which are dimmed probably referring to W2012 server). The interesting thing is that as alternative I am also asked for a system image either on a backup hard disk or DVD. Is there any way to extract the image from the DX4000 to be put on an external hard drive to be connected to the laptop and proceed with the restore using the W2012 boot.wim? In that case I could solve my problem.

I tried the W2008 thumb on another older W7 Vaio laptop. In that case the boot works correctly however I get soon stuck again as the realtek PCIe GBE family controller is not recognized at all. I managed to overcome the problem by using a USB3-Ethernet adapter, in that case the Windows 7 driver has been recognized and the W2008 boot.wim managed to connect to the server.

The process with the W2008 thumb seems working OK on an old HP Vista pavillon (now upgraded to W10). However I did not start the real recovery but at least the W2008 boot.wim worked correctly, the LAN card was recognized and the W2008 server images are shown.

Strangely enough the HP Spectre boots W10 without problems even with securboot off and legacy enabled. Back to the original issue, do you think it might be possible to move the HP Spectre image from the DX4000 to an external hard drive in order to be used by the W2012 boot.wim which boots properly?

thanks

There is a tool on the interweb that will pull a backup from the database but I think it makes a vhd that you can open but not “run” nor do I think it could be used as you desire.
http://wiki.covecube.com/WhsDbDataDump_2.0

I am curious if you have a Win 7 iso/install thumb if it will boot and get to the setup screens with legacy disabled. I think the boot.wim technology would be similar. My concern is and I can only guess as I do not have one, but legacy is going to emulate BIOS and if you get past all the boot issues and start the client restore wizard it will give an error saying you are trying to restore a uEFI box and you booted BIOS

You perhaps should try to contact WD support. This thing is supposed to be supported by Microsoft to like 2022 but you cannot contact MS about it because it is OEM. I will try to ping the DEV team, but they mostly ignore me these days.

Does this lappy have the Intel Raid? FWIW when you try to google stuff search for WHS2011 and not DX4000 or WSSE. It is the same and you will get more hits

You might also post your issues to the Microsoft Forum. Perhaps one of the moderators may have some luck pining MS. You might mention it is supposed to be supported til 2022, but that may just be security updates.

You may also be looking for a Thecus Box to upgrade to 2012R2 I have bought two w2000’s from new egg at 250 each, found two on ebay for 179 each. Then last week Newegg had the W5000 for $250. I did not need it but bought one anyway. 5 bays plus a 500gb SSD AND the Server software !

edit forgot the ms link
https://social.technet.microsoft.com/Forums/en-US/home?forum=smallbusinessserver2011essentials

Hi Gramps,

Interweb tool: funnily enough this tool fails with an error before selecting the volume of the HP Spectre backup. With all the other images (i.e. of the other laptop or workstations) it works ok :frowning:

I tried to boot HP Spectre with a pretty old Win PE CD and even with legacy enabled it fails with a blue screen error, with legacy disabled the CD rom is not even recognized. The same with a W7 DVD (not recognized with legacy disabled). Just for info an Acronis Ture Image 2014 recovery DVD is recognized and loads properly with legacy disabled

That is sad. Obviously technology has changed in 10 years. The DX operating system was what they call feature complete probably in 1996, 97 at the latest. That dude who updated the boot.wim and the 2012R2 boot.wim seem to verify this.

I’ll ping Microsoft but I would not have high hopes. Like I said if you can get a deal on a Thecus you could still use the drives from your DX

of course moving to Thecus or similar NAS would be an obvious choice and sooner or later I will have to take into consideration the final solution. However I am quite unhappy of having spent roughly 5K€ (plus roughly 2K€ of extra costs for the expansive compatible disks) for two DX4000 without having been able to use them as I wish since almost the very start. The last sw releases from WD helped to overcome the major issue of the unavailbility of the compatible disks, however as soon as you solve one problem you face another one like the impossibility to recover an image with a modern laptop (unless of course thinking to fairly complex hw operations of moving hard drive to another machine which among other things would invalidate the warranty). Really a pity.

Is there a thread in here where I said the Dx4000 was a good match for you :slight_smile:

JK, yes I know it is disappointing. I am very sad WD pulled out of the Windows Market. But it is what it is.