DX 4000 question(s)


Im new in this forum :slight_smile:

I just bought my DX4000. It the 12 TB(4 x 3TB).

I wanted to use it with 3 disks and keep one for backup. But when I start first time the DX4000, it did’nt give me option about using 3 or 4 disks and made a RAID 5 with 4 disks. I try to remove and use recovery to force it to have 3 disk and give me 6 TB of space… but it won’t work. After reading in this forum… here the fact.

1 - For now, My DX4000 is setup with 4 disks. (8.93 TB free)

2 - I have a USB flash drive but I cannot make a recovery flash drive because I only own USB 3.0 flash drive (no 2.0).

3 - I cannot access my DX4000 for now but I can ping it.

4 - I download the ISO file for PANAM and checksum is OK.

My question : How can I downgrade the DX4000 to use 3 drives and have about 6 TB free (without error), to kept one drive for backup?

Hope I’m clear :slight_smile:

Thank you for any help!

My Thoughts

I have used USB 3.0 thumbs, so that does not matter.  But aparently the wizard does have trouble seeing some thumb drives reported by others.  I have not been able to duplicate this. You will need a 16gb thumb that the wizzard can see.

What you want to do may work.  I have not tired it with a 12TB box, but it will work on the 8TB box.

Yor first step is to create a thumb drive to do the middle step in the wizard.  I think it is recreate Storage.  Before you do that you must clean each of your drives in another PC has they have the hidden raid info on them and they will try to be a 4 disc array forever. (DISKPART /clean, be sure you clean the correct drive(s)) Once you clean your drives never again put 4 drives in the box at one time.  You have no control over the raid. If you put 4 in at one time it will always expect 4 drives.

Since WD does not actually ship a box with 3 drives, my vote would be to start with just 2 clean drives

After you do the recreate wizard look in the wd folder of the thumb drive for a log file.  At the end of the log file and with just 2 drives it should say something like raid mirror configured.

Then do the bottom/third step, recover my server.  After it is up and running you can add the 3rd drive and it will automagicly convert to raid 5.

Again, if you only want 3 drives, never put the 4th in the box or it will use it.  You have no control over this.

1 Like

Well, im not lucky with the DX4000 :frowning:

It won’t work for now to rebuild with 2 drives. I did what you told me and I also read somes others posts.

1 - I DISKPART /clean all 4 disks

2 - I initialise 2 disks

3 - I put them in the DX4000

4 - I boot the DX4000 with USB Flash Key to recreate the RAID.

5 - On LCD, I saw this :

  • Initializing Ok, Loading…
  • Recovery Initializing… and after 3-5 seconds, I got this message
  • Recovery Invalid config.

So now, I mean miss something to do or im not doing something well… any idea ?

Very very very weird !!!

It has worked !

What I did ?

1 - Recreat a new USB flash Drive.

2 - Clean and initliase 2 disks

3 - Put USB Flash Drive on DX4000 but not the same USB port…

4 - DX4000 start but when is was time to recover… He was in French and did all the work good… at the end… he said that all it ok…

So good news… almost everything working…

I was able to run the DX4000 with 2 drives and now, it have RAID 1 with 2.94 TB left. I install hotfix for uEFI and finish update on windows server and i was able to took 2 backups from twos computers (one on Windows 8.1 and one on Windows 7).

Now, I read the install guide (the one with 84 pages) and it is write that I only have to put a drive and he will convert to RAID 5… but on dashbord, it only said Hard Drive : New drive.

After the night, I shutdown the DX4000, remove the 3third drive, start the DX4000 and added the 3third drive again. Now, it is not saying Hard Drive : New drive BUT juste Harddrive present. I reboot again and now, it say New drive… but nothing about reconfiguring RAID 1 to RAID 5.

So, what I have to do to have a RAID 5 instead of RAID 1 ?

By the way, thank you a lot Gramps for all your answers (in all forums sections hehe)

You siad you initialized the drive(s)?  Can you just diskpart/clean and try it.

1 -I stop DX4000

2 - I DISKPART / clean + initialise one

3 - I start DX4000

4 - I put the drive into the DX4000.

Here a screenshoot

On LCD of the DX4000, Drive count is now egal to 3.

But, there no information that the drive is converting to RAID 5… and Available capacity still the same.

Like I said, try it with just a clean drive, do not initialize it.

Again my experience is based on an 8tb box, the 12 may be different

Thank again !

I did what you said…

At this moment, the FAN of the DX4000 running faster… like it was in the first setup…

First time I insert a drive, drive count was 3 but I have to reboot to see the blue led for the third drive.

Now, it blue and all the blue led seem too work…

How long it can take if is working ?

Seem not working…

I rebooot the DX4000 and show same information in Monitor panel.

Is there a log that I can read to help to what happen?

There is a hidden folder c:\wd in there is a log folder.  Perhaps something in there.

A reboot should not be needed, it should just start coneverting

Thank Gramps for the answers.

There were nothing in the log… I remove and put again drive and there no logs writted.

So, I choose to recreate storage but with 3 drives in… instead of 2 like it was… The result that after I created the USB Flash drive to be in default factory… (the process was very long to format the RAID …) He boot but OS never load… was always on loading…

So, now, I recreate the RAID with 4 drives in… like he was when I receive it… just hope that it will work :slight_smile:

Now, it formatting … he should be very long :frowning:

I give you result of this soon I have finish formatting RAID

When you recreate with 3 drives, did you clean the drives first?  There should have been a log file on the thumb drive you should have looked at before you did the recover

Yes, I diskpart/clean and initialize them. Like I did with it worked with 2 drives (and was in RAID 1)

Good news!

Everything working well  now !

I mean, I have 3 drives in RAID 5… Yesterday, when I finish rebuild to factory with 4 drives, I was in front of the LCD panel… he was rebooting and I saw OS LOADING… I was thinking… he wasn’nt work again … but I was wrong… after about 15-30 minutes… I saw a message telling that he was installing DRIVERS…  he took about 1h30 hours to finish the initial rebuild factory…

So… I choose to try again to rebuild but this time… with 3 drives… He format while i was sleeping :slight_smile:

At this moment, I setup the server with 3 drives…

The moral of this story ? : It take very very long time to rebuild and when you think you have finish… you still have to wait. Rebuild with RAID 5 is taking more time than RAID 1…

Good news !!  Just remember to never put the 4th drive in the box as it will use it.  Just leave it on top of the box to have if it is ever needed.

  1. I dont now if im crazy but with 3 drives… the drives seem always working…I always hear the drives making somes noise…

I log with mstsc to see if there a processus running but nohting… But When i was on raid 1 with 2 drives… I have’ent here a noise like that… it is because of RAID 5 ? I degrag disk and on Dashboard, everything see good.

  1. When I boot and I have a external USB drive connected, DX4000 not boot… stick on LOADING OS… if i remove the USB drive, he boot normaly… How to avoid that ?

Thank for any help !

There is a long thread in here somewhere about not booting with some usb drives attached.  But again, I think some said just wait and it did boot.

Again wait on the drive noise.  They may be doing a full initialization.  Give igt a week and see if they are still noisy

Thank again Gramps for your answers!

For the “noise”, I have fully update windows and did a backup for a computer. The only thing is this “little noise” that I have’nt hear when I was on RAID 1.

Because i Have a cheap NAS for my home on RAID 0 and I dont hear it when there no action on it.

As you said, I will wait a week.

Thank again for your answer!