DVD Video TS Folders

Hi a newbie here. I’m trying to play dvd video ts files to my new smp over the network from my wb live tv hub. On the hub they play perfectly but as someone else pointed out they appear as folders on the smp. Chosing a video vob file will get the main menu of the dvd to come up but playback seems to slow down to half speed after about 3 seconds and the audio stops. Does anyone know if this is a network issue or can’t the new streamer play dvds from ts folders? I’ve tried various settings with the same disappointing results. Any help here would be greatly appreciated.


A bit more testing has revealed that iso files on the live hub stream perfectly to the smp therefore the problem must be with my new wd live streamer. The only reason I bought this was to stream video ts folder dvd’s upstairs so if it can’t do this I’ll be returning it - I assumed because the live hub can do it so would this. Has anyone managed to get dvd folders to play on this device yet?

All my DVDs in video_ts folders play fine, both on my attached hard drive and from my server connected via wired ethernet.  I just highlight the name of the DVD folder that I want (not the video_ts folder, but the parent folder which contains the video_ts folder) and press the Play button.

Thanks for your reply. Can you confirm that you’re also streaming using samba share networking? I can get the files to play using media servers but then there are no dvd menus just playback of indiviual files. I might have a dodgy unit then if it’s working ok for you.

littlemalcom:   I responded to your ISSUE post.

Are you using WIRED or WIRELESS?   Because I do see what the issue might be if you’re using Wireless.

When I streamed a VIDEO_TS folder via Samba, the bandwidth being consumed was about 3-5x what it should be for DVD playback.

The DVD Standard uses no more than 10 megabits per second, but my NAS was reporting that it was sending 30-35 megabits per second.   So something is going wrong somewhere in the WD’s networking when playing DVD Video_TS folders. 

If I play the exact same DVD in an ISO, the bandwidth is normal 5-7 megabits per second.   

If you’re using WiFi, 35 megabits per second may be too difficult to maintain.

I did NOT experience any stuttering or playback issues in my setup which is all wired.

In further testing, I noticed that other containers also play normally, so it’s not just a generic network issue; it’s an issue tied to specific media types / containers.   I can also reproduce the issue with certain video formats in an MKV file.

1 Like

Thanks again for the info. The stuttering happens whether it’s a  wired or wireless connection. I hope there will be a fix for this soon as the only reason I bought the smp was to stream dvd folders and I’ll probably return it if it won’t. What about mp4 files also stuttering is that the same problem? How likely are WD to try to fix this now that they know it’s a bug in your opinion?

I haven’t tested any MP4s, so I don’t know if that’s the same issue or not.

Some further observations.

I have a wired connection with a Windows XP box serving network shares. The network shares have a mixture of

.iso, VIDEO_TS,mp4 ,m2ts,MKV and .AVI format media.

This has been my setup when using the previous Live Plus.

I have had   no problems when streaming .iso,VIDEO_TS folders,mp4 ,m2ts or AVI.

I am having some issues with MKV formats refusing to play… but these are newly generated and I am still trying to

debug why these MKVs refuse to play.

…Other than that  MKV issues,no problem streaming any format to the SMP.

Hmm this is very confusing…some people are reporting problems with dvd folders while others say they play fine. I could accept that there might be a problem on my network if nothing streamed from the live hub but all other filed types except mp4 do play ok. I really don’t know whether I should return my unit or wait for a fix in new firmware.

Why stick with folders anyway? Just output to ISO and be done with it. Works fine for me over shares.

Well… the main reason for buying a second box was because my live hub plays dvd folders perfectly and I assumed this would as well. I’d have to spend weeks converting thousands of dvd’s to iso and frankly don’t have the time or the will to do so when I know they play well on other devices. I still can’t work out whether I’ve just got a duff box or it just isn’t capable of straming dvd’s with the current firmmware.

If your DVDs are stuttering with WIRED playback, I would double check your network…

Make sure none of the systems are reporting errors in their network statistics, etc.  

I’ve never seen a hardware defect be responsible for a very specific playback symptom…  I guess it’s a remote possibility, but not at all likely…

Also, if you’re streaming from a PC, bring up the Task Manager and go to NETWORK STATISTICS and take a look at how much bandwidth these specific movies are consuming.

Thanks for you suggestions but I’m almost certain that my network’s running fine for the following reasons: I have an atv black on the same network that plays dvds from the live hub perfectly using the buit-in media player. I also have a sony internet tv that can play the individual files in the dvd folders without stuttering. I can only conclude it’s something in the frimware that’s casuing the issue. Also… as I mentioned earlier the smp will play the individual files if I set the share to media servers instead of a samba share and uses twonky from the live hub - so it can play the files  - but just not as a dvd with menus. 

One other question… does everybody elses player take over a minute to boot up? Mine comes on with the WD logo then appears to go off again before restarting the WD logo screen about a minute later?

It’s been a frustrating experience so far with this device but hoopefully there’s a solution coming soon.

There’s definitely a bug that causes certain video formats to consume way too much bandwidth.

I’m just trying to figure out why you get STUTTERING on DVD Video_TS and most others don’t…   Presumably we’re all having the same bug that makes it consume more bandwidth than it should, but that’s not been verified…   And if that IS the case, then the only thing that makes sense is that either the HUB or the NETWORK is unable to cope with that errant bandwidth demand.

I suppose it’s entirely possible that your Hub can’t cope with the 30-40 megabit per second demanded by the WD.   Is IT wired or wireless?   Have you tried streaming them from a higher-end server like your PC? 

It makes sense that none of the other devices or formats have problems, because they are (again, presumably) using only 1/4 of the bandwidth the WD bug causes.   It also makes sense that streaming them via MEDIA SERVER, or playing the individual VOB without menus causes no issue, because the bandwidth required is again only 1/4 what you’re consuming when you play them in DVD-mode.

My SMP takes about 40 seconds or so to boot up from COLD.   Yes, there are two different Splash screens…  The WD Logo with a cloudy scene, then my TV goes blank for a few seconds, then the WD Logo + “LOADING…” and a different cloud scene… then the menu.

It only takes about 3-5 seconds to boot up from Standby.

Wow thanks for your speedy reply there. I’ve got a wired setup here using 200mps homeplugs that can handle anything I stream though them…that is until now. I didn’t realise there would be a difference in bandwith just playing individual vob files so that makes sense.

I’ve got the very same folders on the wd hub as backup on a wd live nas but when I try using that as a source I get identical results ie. stuttering after 10 seconds play. If it is my network it still wouldn’t explain how the atv2 can stream dvds flawlessly from the nas or live hub on the same network in the same room?

Thanks for bearing with me here much appreciated!


That’s because the ATV2 is consuming “Normal” amounts of bandwidth.

A Full-Blown DVD *CANNOT* exceed 10.5 megabits per second of bandwidth.   That is in the DVD specification.

But the Live-S is consuming 35 megabits per second when it’s reading VIDEO_TS folders.

It consumes NORMAL bandwidth when they are ISOs instead, and it consumes NORMAL bandwidth when it’s reading the individual VOBs without being in DVD-Mode.

So THAT is the Bug.  

I would lay 10-to-1 odds that if you ran a Cat5 patch cord instead of using the Homeplugs, that the Stuttering would vanish.    

That doesn’t mean the Bug is fixed of course, but it would indicate that your Homeplugs can’t handle the higher bandwidth.

WELL Tony …(drum roll)…you were right! I brought it downstairs, connected it up, and bingo everything plays! So what you’re saying is I can’t use homeplugs or wireless if I want to watch it out of 5e cable range which kind of defeats the purpose of having a second box for an upstairs bedroom in the first place mmm.  

Some advice needed here then : should I return it or do you think there will be a firmware solution for this bug anytime soon …because basically it’s useless for my purpose until there is? I know it’s my decision but I’d appreciate a second opinion here.

many thanks again for all your help so far!

I wish I knew when or if it’ll be fixed.

All we can do is wait for your Issue Report to be addressed by the WD Staff.

But my general thoughts on things like this is:

Buy the box for what it DOES, not what it MIGHT do.   So if it’s not working for you with reasonable workarounds, I could certainly understand returning it and then perhaps re-purchasing when it gets fixed.   It could be a few weeks, it could be months… :frowning:

There’s also the possibility you might be able to get your homeplugs to work better…   Remove them from any power strips, voltage regulators, noise filters, try different circuits, etc. etc…

Sometimes plugging one homeplug or the other into a different circuit and then running a Cat5 cable to make up the distance can dramatically improve performance.

Thanks for your advice Tony - I’ll give it a few weeks to see if WD do anything about this issue. I tried your suggestions with the homeplugs but it made no difference. 

One more thing - do I have to contact anyone else regarding this bug then or is it now automatically logged through this forum?

Converting to ISOs mostly likely needs space rather than time cause it can be done with ImgBurn unattended.