DVD Play

Problem with WD TV Live Plus  (running latest 1.03.39 beta) playing DVD-in-folder

I need some suggestions from someone more experienced with this machine…

Odd behavior.  I played DVD ripped into a folder.  When I press Play on the folder, it does start the DVD menu, but I cannot make any selection.  The up/down/left/right key on the remote does nothing.  Pressing Enter or Play affects only the menu’s VOB (pause the menu’s VOB playback) but does not start the movie.  The DVD menu normally has a red-bar by the default choices for this DVD, WDTV’s play back show no highlight for the current choice.  I can however press NEXT to skip to the next VOB.  The system also saids I the movie no SubTitle (it does).  Playing it using PowerDVD (v5) it works fine.  This is not an issue with a particular DVD.  All my DVD rips behave the same.

It is as if the individual VOB is being played and not VOB as part of a movie.

I tried doing it using both network share folder and folder on local USB drive.  Both network and local drive has the same behavior. 

Any expert out there with some hints?


You have included the VIDEO_TS folder in the rip, right?

I know it is tempting to skip it to make playback easier, but the Live requires the VOB’s to be in the VIDEO_TS; your description sounds like it is missing.

Otherwise you might try ripping to an ISO file instead


To add to what Cocovanna is saying:  You must include ALL of the DVD’s VIDEO_TS file structure; the VOBs, the IFOs, and for good measure, the BUPs (BackUP ifo files); ALL must be included.

All of the files MUST be in a folder called VIDEO_TS, and that folder must include content that’s ONLY from a single DVD (in other words, you’ll need a separate VIDEO_TS folder for EVERY DVD.)  For that reason, it’s often more convenient just to store them in ISO files instead.

Rick, By your description I am not sure if you know that you need to select the VIDEO_TS folder, then press Play. Once it starts playing you need to press the Options button, then select Menu in the options. Once you do this you have normal DVD navigation. 

Thanks!  You guys are good!  That works!

I tried putting the files in into VIDEO_TS folder before, but I was pressing PLAY on the folder.  That didn’t work and I went on to try something else and found nothing worked.

With you folks confirming that it should work with VIDEO_TS folder, I went back and try again with that folder.  I tried  something I have not thought of before: press Play on the VIDEO_TS.VOB in the VIDEO_TS folder!

You are right about this being confusing and too complicated.  I should consider putting that in ISO.  Converting it to ISO will make that easier to manage.

Thanks again!


More on when you’ll get menus or not here.