DVD Menu issue with new firmware 1.04_v

Hi There,

I’m a newbie here, just got my nice new WD TV Live for Christmas. :slight_smile:

The biggest reason I bought it was that it can play ISO files now with DVD Menu support.

I immediately upgraded to 1.04_V firmware to test this feature.

But when I try to play an ISO file, this is what happens:

  • I see the list of all my ISO files in the folder

  • They play nicely in the preview pane (on the right) but already without the DVD menu

  • When I hit “enter” on the remote to play the fle, I get black screen with the Status Bar on the bottom and it wouldn’t start playing the file at all. I waited a couple of minutes, and nothing happens.

  • When I hit “back”, it goes back to the folder view with the list of files correctly (so it doesn’t freeze, it just wouldn’t play)

  • When I hit the “right” button and activate the preview window, and then hit “enter”, the file starts playing, but without the DVD Menu and it goes in a sequencial mode during playback.

  • When I hit the “options” button to try to access the DVD Menu from the options list on the top of the screen, it’s disabled.

Can somebody pls help me what to do, How to get the DVD Menu support?

It is really important as I have a lot of DVDs that I either ripped from DVDs or created files specifically for play in a Media Player.

THX for your help!



ps: the ISO files were either ripped with ImgBurn or created with Pinnacle Studio v12 and on the PC they played perfectly with VLC player so it seems the files are OK.

HaliBali…  Was it working BEFORE you upgraded the firmware?  If so, what version were you using before you updated?

Other than the “Black and No Playback” you’re describing, everything else is normal.   You can’t launch DVDs with Menu Support by doing the Right/Activate Preview  (a lot of people like this as a way to skip the menus if they don’t want them.)

I haven’t tried to rip any of my Pinnacle-made DVDs, but it’s possible the menu structure is not capable on the Live.  And also, just because VLC can play it, that’s no guarantee that the file is “Good,”  it just means it’s “Good Enough” for VLC to play it.  

Hi TonyPH12345,

Frankly, I haven’t even tried with 1.02 which was the original firmware as I read somewhere that this firmware did not support DVD Menu at all.

Do you have any suggestion what should I try at least?

I’m not aware of different standars of DVD Menus, I mean it played in VLC, if I burn a DVD from this ISO, tha menus also work perfectly.

What should I try to do? Use a different ripper?

THX for any ideas…



No, there’s only one DVD Standard, but unfortunately there’s different IMPLEMENTATIONS of the standard, as well as more laxity in interpretation of standards as the DVD is being read.

You could try the free trial of DVDFab, which is what I use for my commercial DVDs…

Hi,  just  use the play button rather than the enter button on the remote,

Hi there again,

In the meantime I tried to rip a “proper” DVD with ImgBurn to see if that plays correctly on WDTV, and “unfortunately” it does. Which means that you (TonyPh) were right. Probably the Pinnacle DVD Menu implementation is not compatible with how the WDTV wants to interpret it, so it doesn’t play.

That’s a big shame for the moment as my plan was to create ISO files of my own videos and I always used Pinnacle. I might need to change the video editing software it seems.

I will still try to contact WD support to check if they are aware of this problem…

THX for your help!



I have had same problem with what you have explained I have tried anydvd and magic copeir and with no luck most play with menus. Some that don’t I can create a whole iso copy of dvd just not the movie itself and get it but most of the ones when I have this problem on I have to do main movie ISO only which cuts out the menu and starts movie once you hit enter on the iso file. I have a WD live plus and has been like that out of the box. I do a vob format with video ts file and seems to be fine. My dilema is I wanted a way to be able to view all my movies without looking through different hard drives and a playlist creator can do that but with iso files it won’t reckognize vob and play whole movie. Plus iso is a bit cleaner file system. If anyone ever figures out the real solution it would be great to know if any

I have the exact same issue but can add that also PowerDirector menus are not compatible it seems.

Can WD implement a fix for this please? These are the most used home authoring softwares so it should be some priority behind it!

PowerDirector does a lot of strange things. For example, it allows smart rendering of many camcorder clips, called SVRT, but it fails when you try to smart render a file that was produced by PowerDirector itself. So it isn’t even compatible with its own files. You can force PD to do so by turning on a switch in the settings, but then it will produce a stream full of errors that have to be corrected by 3rd party tools. If PD DVD menus aren’t played correctly, I’d rather assume that the problem is PD, and not WD. PD is still a rather buggy piece of software; for DVD authoring, I’d rather use an approved software like that of Tmpegenc.

Still if you want to do some “easy” DVD authoring I do not see tmpegenc as an option. Pinnacle is what I have used the most, just started to try PowerDirector and then there is Vegas.

Since all other sw and DVD players are compatible with the iso output of these programs I find it very strange that WD Live is not.