DVD .ISO question for WD Live TV Plus

Hi all,

This may have been answered previously, but I haven’t been able to locate it, so I’ll ask it anew…

I have the WD LTV+ which I just purchased I am trying a few different formats to get what I want, which is;

DVD menus

DVD cover art as the icon

Press play on the cover art, the DVD menu starts

This works great for all my AVI files (which I ripped for use on XBMC), I followed the hints in these (excellent) forums and was able to get that working (albeit without DVD navigation). I have also done a DVD copy to the VIDEO_TS folder and this works great as well including the DVD navigation. so now, the next step… An ISO image. I created an ISO from a ripped VIDEO_TS and from the original DVD. when I click play on the cover art, the movie plays, but I can’t get to the DVD menu.

Any ideas as to why?

I have the WD Live TV + running  Firmware 1.04.31 with the data on a WD 2 TB e Book  direct connected to the LTV+ and I use DVDfab to create the ISO.

On a side, but related note, I also tried using VOB merge as suggested in a previous thread, I did not get menus and the VOBs did not play as I expected even though they were in numeric order.

Thanks in advance for the help.

When you ripped the DVD, did you just rip the Main Movie or did you rip the Full Disc?

I believe you must rip the full disc for DVD menus to work correctly.

If you’re using a free ripping tool like DVD Decypter or DVDFab HD Decrypter, you should be able to rip straight to ISO in one step.

That’s how I did most of my discs and they work fine.


Thanks for the reply, yes i ripped the full dvd and when I mount it using Winmount and play it in WMP, it works as expected with DVD menus.

I also re ripped it and selected “change DVD playback order” and “Jump to main menu when disk is inserted” with the same results.

The mounted ISO in WMP shows the FBI warning, then the commentary CYA then the DVD menu. The unmounted ISO showed on WDLTV+ played by hitting “Play” on the dvd cover art goes directly into the opening credits of the movie.

I think you need to press ENTER to get the menu to play. I just tried it and it works for me, but I just use the file list mode.

PLAY plays the main movie without the menu.

1 Like

Ahhh, Ok, let me try that.

Ok, I just tried that it , and while not ideal, it does work.

When I say not ideal,  pressing enter brings me to the folder, i then press enter on the ISO and it works as expected.

So, if I want to just watch the movie, i click “play” on the cover art, if I want to got through the DVD menu for scene selection or extras, I “enter” then “enter” on the ISO.

Still 100% better than XBMC.

Guess I’ll have to re-rip all my DVDs since for XBMC I had to rip them as AVIs

Thanks again for the help.

Glad it is working.

Just a comment though, if you are using ISO’s I don’t think there is any reason to have them in seperate folders. I have my ISO’s in folders that indicate the movie genre. So I don’t have to do the double ENTER. Just select the genre folder, scroll to the ISO and press ENTER.

However, I just use file view mode. To get cover art this way, my understanding is that if you put a movie_name.jpg (i.e. where movie_name matches the root of the filename) then it will show as the cover art.

Interesting… I will give that a shot.

Thanks again!

Just an update for anyone following this, the suggestion worked great.

I created a folder called “Media” and placed all the .JPGs in there with the name exactly the same as the .ISO (I mean exactly, I tried with different cases and it didn’t work so case matters). Now I can go into the folder, see all my covers in thumbnail mode, hit enter on one and it brings up the DVD menu.

I absolutely LOVE this device!!

Getting the Logitech Universal Remote next (the 300i, i can’t spend 100 dollars on a remote, 39.99 is much more resonable)

Thanks once again!