DVD ISO playback quality poor compared to mkv-"jaggies"


#1

Hi,

I have both ripped a DVD to iso and used handbrake to encode to mkv and the iso playback quality is poor.  It exhibits “jaggies” really bad whereas the mkv does not.  Is this normal?  Anything I can do to fix this?  My preference is to use iso since its faster, but I do not like the look of the resulting video.  Thanks.


#2

No, that’s not normal.  Playback of an ISO (properly recorded) should be IDENTICAL to if you put the DVD disk in a player.


#3

Sorry, to clarify, this is when streamed to the WD Live, not played on a player.  And I am sure my terms are wrong, i.e. encoding etc, but with handbrake I am using h.264, so I’m wondering if it is sort of upscaling the resolution or something?  (Not a video encoding expert, just getting started)


#4

If you ripped the DVD (say, using AnyDVD) without re-encoding then it will playback identically to a DVD player (quality will be the same) – that’s what Tony is saying.  IOW, to put it another way, there should be NO jaggies when played by the WD TV Live unit.

If you re-encoded the file using Handbrake to an MKV container then the quality can vary depending on what preset or settings you used.  If you use the High Profile preset, for example, you should see no difference in quality, but if you used the iPhone preset you would.

All of my MKV files are made with Handbrake using the High Profile preset – and whether a blu-ray or a DVD the quality is exactly the same as the original disc.


#5

Got it, OK I see what he was saying now.  I guess what I am wondering is if maybe the WD is playing in a 480i mode on the ISO instead of 480p but handbrake is encoding the h264 in 480p or something like that.  Again, this is all pretty new to me so I get lost in what all is happening when re-encoding etc.  Also, I have all new AV gear so I am not sure of all the settings and customizations etc.  I will try the disc in the player just to compare.


#6

Handbrake cannot encode in interlaced mode, so anything you put through it will be encoded progressive.  But that won’t cause issues IF you use the right preset (because the presets have the right things turned on to compensate for this).  As I said, use the High Profile preset – that’s all you need to do (and don’t mess with ANY of the other settings with the possible exception of passing through the DTS or AC3 audio if you have a surround sound system).