Dvb logic/tv mosaic

i have been using a tvbutler with dvblogic server software in my pr4100 plugged directly into usb port on the front .this allowed me to watch and record live tv through plex on my amazon fire tv box without issue. however since dvblogic became tvmosaic this no longer works. tvmosaic say they are waiting for a sdk chain/toolkit from wd , does anyone have a work around in the meantime?

I have tried to set it up in OS3, both native as with docker but I’m hitting a lot of issues: outdated libc, missing dbus, no dvb tuner drivers in kernel … The work around is to get the debian setup and it’ll all just work.

I made a TV Mosaic package. It’s the replacement for DVBLogic
Get it here and let me know if it works for you.

Note: you need a TV Butler DVB stick and a TV Mosaic subscription to use this!

the tv mosaic file seemed to install correctly on the pr4100 but said i needed to install the remote app when i attempted to configure it. unfortunately i only have amazon devices (fire phone and fire hd6) and the app from the amazon app store will not install correctly . i had previously configured my tv butler using plex on my dell a.i.o. but after scanning and finding channels plex asks for the /path/to/your/xmltv-file.xml which i do not know . if you can help with this it would be much appreciated.

sorry my mistake plex will find a tv guide for my area if i only input the first part of my post code not the full postcode as i tried before. plex is populating my guide now. i will update later. thanks

new package seems to be working as well as it ever did before thanks. tv mosaic app has now appeared on my fire phone aswell but just tv guide just comes up blank. i will try plex app on fire tv/phone and tab later and let you know if everything is ok.
thanks again

watching tv on fire phone (plex app) works perfectly maybe even better than before however i no longer have the ability to record tv using plex web on pc or plex apps on mobile devices. im guessing thats because i need to pay for tv mosaic plus even though my tvbutler came with the server software . if you can help with this please let me know .

DVB on Plex requires a premium account, unfortunately I don’t have one at the moment.

Indeed, it seems like the license is required to record TV, which is unfortunate… but DVBlink also required it and you can convert your license on the website.

Hi Tfl,

Is there anyway to update the TVMosaic server software on my PR2100?

Awaiting your answer.

I made a new version and added a (slightly hacky) auto-update script to the build.sh script.
Available in the link posted earlier.

1 Like

Thank you very much. Im gonna try it out today!