Duplicate Video Files

Continuing the discussion from Duplicate video files:Has this issue been resolved, i am getting the same, i access my video folder, and in the sub folder i see duplicate videos files, i am accessing the WDMC from my TV to view and watch the videos !

More information is needed. What brand/model of TV. How is the TV accessing the My Cloud; DLNA or some other method? What is the Twonky administration page (http://wdmycloud:9000) indicating for Media Receiver type (Settings > Sharing > Media Receiver), does it match your TV manufacturer/model? If not what happens if you change it to match your TV manufacturer/model? Is Media Serving disabled/set to Off (via the Dashboard > Shares) on the Smartware and Time Machine Shares or other Share(s) used for backup or file syncing (like with the WD Sync program)?

Have you read through the following thread?

sorry for late Reply!

I am actually now suffering another issue. i will explain later and am digging around for some answers.here are the details as per required information:TV is LG 55UF950TAccess is being through the EA6900 - AC1900 Linksys Router (Wired : TV to Router)I have never actually checked the media reciver type - what is the relation - Also duplicate thumbnails are increasing i can see 4 thumbs per file, and not for all video files, only certain foldersMedia Serving is onI never used smartware or timemachine, and i am assuming they are off or whatever the default factory setting easyTwonky: http://wdmycloud:9000. I will go through the thread you mentioned now.
On another note,
My WD now is acting crazy, i cant access use any of the WD apps on my Android 6, i cant access the dash using the IP or the name wdmycloud/ i can access files through UNC \wdmycloud and its quite fast, never see it being this fast. always had suffered from performance issues.
What i tried is Reset the device, restart the device, and that is it. after i reboot it works quite well and fast accessing from the TV or from the UNC and the Dash, and then two days later i cant access it. i have rebooted the device 3 times so far.am about to open a case, also prepared my basket with QNAP 253A 12 TB
Thank you in advance, and thanks for responding back then and for future response.

An incorrect media receiver type may cause the client DLNA (the TV or other device) to improperly display the content the media server is serving up.

If you have not done so already, make sure to configure the My Cloud with a static IP address either through the router’s administration page (the recommended way) or through the My Cloud Dashboard > Settings > Network page.

If you have downloaded album or cover art as a separate image file rather than embedded that album or cover art into the media file that may account for duplicate names (one for the image one for the audio/video file).

Sometimes doing a database rebuild within either the Twonky Administration page or within the Dashboard > Settings > Media page may fix certain issues.

And performing a proper reset (4 second reset or a 40 second system restore) may fix certain issues, especially if those issues have started to occur after a firmware update.

And make sure to update the firmware and mobile apps to their latest versions. For mobile apps sometimes uninstalling then reinstalling will fix certain issues.

Hi Bennor!
i have had the WD my cloud for over 2 years now.
and i never setup the media type on twonky. actually not until recently i knew about the Twonky through the searching for issues i have been facing. never had that issue before.
one thing i have changed after the first Soft Reset is not used Static IP address. i will do that again and see how it goes.
When you say Album cover? you for the movies? I have WD my TV connected, i don’t download any album Art

i have performed a database rebuild twice, especially while having to face Building thumbnails and DLNA SCAN, which i dont think will ever solved.
All my devices have the recent FW, not only facing the issue on Android, but with Blackberry Passport as well.
raised a ticket, this will be the last straw. if not resolved and became stable for at least week, i am no longer using WD for Cloud/NAS services.
Welcome QNAP.
thanks for the quick response.


If one gives an image file the same name as the media file (or embeds the image into the media file) then the My Cloud will display that image file as the cover art for the media file. For example.


Further is one gives an image file the name folder.jpg and places it in a folder, the folder and all media files within it that don’t have artwork assigned or embedded will use the folder.jpg file when being displayed.

Here is what it looks like using Windows Media Player to access the My Cloud’s media player with the artwork embedded within the media file stored on the My Cloud:

The first step is to ensure the Twonky administration page is selecting the right media receiver type for your TV.

Have you checked your media library directories with a file browser (e.g. on a computer) to make sure there really are no duplicated files?

Assuming your are using a DLNA media browser on the TV, then you ought to be able to see if the duplication problem is a result of the Twonky media server, or your TV. If you open the Twonky UI, you can use Twonky’s DLNA media library browser to see what Twonky thinks it has in its library. If it sees only one thumbnail, then the problem lies with the TV. If Twonky sees multiple thumbnails, then the problem lies with genuine file duplication, or with the Twonky media server.
I had a quick look at the specification of your TV, and it mentions the LG ‘Smart Share’ DLNA app, and a web browser, but no network file server browser that I could find.

Also, which DLNA ‘view’ are you using to browse your media library? ‘By Folder’, ‘Title’, ‘Album’ etc?

Where on the MyCloud do your store your media library (i.e. which share/folder/directory)?

Where have your video files come from? Are they a single file, or are there supporting files with the same name (but a different file extension)? Video extracted from a Humax PVR, for instance, have three files in addition to the .ts video file, which provide EPG information (.epg, .hre, .elu). Twonky doesn’t normally show me these files, and only shows the .ts file.

I would suggest applying strict search rules for your media collection, so that Twonky only looks for video in your video area, pictures in your pictures area, and music in your music area. This is explained in the Twonky FAQ thread. As Bennor suggested, make sure that you do not enable media sharing on any backup directories you use (if they contain copies of your media; that would be pointless waste of space, anyway…).

You might also try turning the media server off, deleting the entire twonkymedia area, and restarting the media server. This, too, is explained in the Twonky FAQ. This is the most brutal restart of Twonky, since it destroys all its settings, and reverts to factory defaults; you will have to restore them, or take the opportunity to set them intelligently, rather than accepting the default values.

One other possibility is that you have other media servers on your network, that are seeing your media library, and Twonky is aggregating these into its library; make sure Aggregation is turned off in the Twonky UI.

You need to be very specific when you say ‘reset’, ‘reboot’ and ‘restart’. What do you mean? A power cycle? a 4-second, powered reset? a 40-second power-up reset? Each does different things. Read the User Manual for details. If you have automatic firmware update enabled, it will probably have done a firmware upgrade recently. This can sometime requires a 4-second or 40-second reset to resume correct operation.

That would be a shame, since you appear to have an otherwise working device. But if that’s what you choose to do, good luck.

Forgot the Twonky User and Password, could help out please: i tried this thread.
Twonky reset but that directory gave me access denied

please let me know how to reset it with out having to reset the whole device

You need to edit the twonkymedia.ini file, not execute it (which is what you tried to do)…

vi /CacheVolume/twonkymedia/twonkyserver.ini

You’ll need to know how to use the vi editor…

Or you could use the nano editor.

There is no Twonky specific user name and password. One uses the default Root user name and password when logging into the My Cloud via SSH.

On a v4.x My Cloud I have no problems opening up the twonkyserver.ini file located in the /CacheVolume/twonkymedia/ folder using WinSCP (https://winscp.net/eng/download.php).

the thing is i recalled i have changed the password, tried the root i am using for SSH - Putty, but it did not work

i know i have set the password, but completely forgot it… i am not sure of i had set a user name, but either ways, i need log in credentials

The image you posted indicates the web address for accessing the Twonky Adminsration page with a web browser. By default that page should not require a user name or password to access via one’s web browser.

To access the My Cloud via SSH you use just the IP address, you do not need to add :9000 to the IP address

You can set a password for the Twonky admin page.

If the worst comes to the worst, you can stop the twonky server, delete the twonkyserver.ini, and restart the twonky server, I suspect. It will re-create the twonkyserver.ini file from scratch, but you would then have to set Twonky up again as you see fit.

Refer to the Twonky FAQ.

I’ve tried all the said,

I am still facing an issue.

I have reset the device performing the 40 seconds method. Reconfigured it, and set up static ip. For the last two days the device is extremely slow and unreachable most of the time, my network devices display an error that device is not on connected

The TV shows me unstable connection, the laptop says network device not found. And the mobile app unable to access device.

Why do u mmi feel the NIC is faulty… How can I examine its a nic issue?

Thank you and regards

Get Outlook for Android

I am at the twonky page, and I see the TV in the media receiver list, and I can select from different types, but it’s advanced media navigation by default. Shall I chnaged it to anything else from the list.

And the media receiver type, there are two for lg.

One is lg dlna DMR and lg dlna player,which one is most suitable, or how can I tell which one is?!

Thank you

Get Outlook for Android

Try them…?

You didn’t answer any of the diagnostic questions I asked, so I’m not sure where you are with your problem, or how I can help further.

Hi there my problem now is not I’m not able to access the cloud anymore at this tournament and I’m not able to access it and it takes too much time to go inside and then it shows an error that it is disconnected

I’ve already performed 4 resets

Get Outlook for Android