Dual 3TB MyBooks only 1 shows

I have two 3 TB MyBooks hooked up to my computer but only one shows up. I want to use one for my iTunes library and the other to back up my library. I had a seagate but it suddenly died and I lost my entire 900 gig iTunes library. Can you only have one 3 TB My Book hooked up at a time? If that’s the case how do I back up one drive with the other?

Go into Disk Magagement it may need a letter assigned. Also while there see if it is online. If not scroll down where it shows the bar and on left side find it like disk1 right click there and select online.


It says it’s offline but I can’t find a way to make it online. I’m running windows 7 on an older compaq with a amd 64 x2 4800+ and 3 gigs of ram.

You have to do this  scroll down where it shows the bars find the drive then move over to the left side where they are indetified Disk 1 and right click there and it should show up in menu just click online. You have to be at the left where is shows Disk 0 or whatever it’s the only place.


1 Like

I have the same problem. Bought a latest Acer Predator and 2 units of WD 1130 MyBook (3 TB USB 3.0). However the Windows 7 finds only one (although for the USB and WD Quickview see the two).

Found in Disk Management the following message at the second (invisible HDD):

Offline (The disk is offline because it has a signature collission with another disk that is online)

If I turn them one individually, both work on it’s own. Both I have updated to the latest Firmware. Both are connected to USB 3.0 and Windows 7 Home Premium is updated to latest.

Anybody at WD an Idea how to solve this issue?

With many thanks and best greetings,



Thanks Joe … after I did my posting of the problem I tried again, and it worked. It is available now … strangely I tried first and it did not … maybe it took a few seconds to think it over that it better follow the right-click.

It seems to work now …