DS6100 Upgrade Windows (Clean Install), Increase RAM & 3rd Ethernet Port

That recovery partition is a disappointment to me. To use it you actually have to boot to windows and hold down shift while clicking restart to get to it.

If you boot from recovery media you cannot access it because there are no raid drivers loaded. Now one time I was piddling with restores, loaded the raid driver, but canceled the restore. Well it showed up though I did not actually follow through to see what would happen.

I think you need to backup everything C: system, etc, except D: (Raid data) to be able to restore and not a bad idea to have your raid data backed up as well unless you do not need it.

I suggest you get a spare hard drive and fiddle with it till you are comfortable you can get to where you want to be.

I think there are too many risks/problems with running the machine as a dedicated 2016 hyper-v host so I am going to open it up again check if I can identify which boot drive is making all the noise and try replace it.

I am just going to do a restore now and probably keep it off my domain and just run everything in Hyper-V or ESXI.

I suppose I still could use it as the domain controller but all my VMs now will be 2016 which if either you haven’t tried, it runs very nice on this machine. I have 32GB ram now so each VM should be having around 6GB each and 2 cores.

Maybe WD will do some sort of official upgrade/support and then I can upgrade the host and retain the VMs, think the plan for me now is to try and keep as little services running dedicated on it.

Thanks for all the help and sorry for chickening out on going RAW 2016 on it.

Chicken!! lol I was living vicariously through your impending install… :slight_smile:

I talked to one of the WD tech support guys, he said he loaded 2016 on his DS6100 at home and it ran great.

I would love for WD to give us an official upgrade option when the final 2016 ships.

Guess I need to try it sometime in a VM. But I fairly certain that Essentials does an in place upgrade. Server standard does not

Essentials does let you upgrade I believe.

Just discovered the noise I was hearing isn’t the drives. Removed the casing to listen to which 1 it was and couldn’t hear anything. Then I realised it was coil whine coming from the motherboard.

I suspected it was a refurb unit, looks like a chip has cracked the casing. Not sure if this is anything to worry about or not though.

Starting the 2016 upgrade process now that RTM is available.

Can’t get it to even boot to USB… going to try doing upgrade first see how that goes before I go back to a clean install. NIC teaming was a pain, disabled it but it kept being awkward.

Upgrade process is now running so will keep this updated.

If anyone knows how I can do a clean install from a USB stick that would be great, going to take the gamble and delete the partitions and start fresh. I have a backup should I brick my machine (hopefully I can restore it)

Upgrade went well, only option was to lose all files/settings.

Data drives are stil there so raid drivers must be working

I think you should have perhaps tried the 2016 essentials sku. It is supposed to keep settings. Server standard would start fresh I think.

Is your thumb drive formatted FAT?

ISO doesn’t support fat32, I used rufus.

It’s all installed now on DC version, seems to work very well. Just setup hyper-v and that’s even let me import my VMs which were already on the the data drives.

Server essentials looks like a feature now you install.

Just about to try it and see how it goes

Not sure what you mean about the iso. RUFAS has a fat format option
Essentials SKU is really Server Standard with the Essentials role pre-started

Advantage to the E SKU is it allows up to 25 users for free

When I tried to format the USB stick as Fat it told me it wasn’t supported as this file system.

I’ve only gone for DC version because it’s a homelab. Don’t need the licensing benefits since this isn’t a production machine anyway.

Would be nice if WD offer an upgrade so I can go from 2012 to 2016 on that box which is my main box

Hello mkelbie,

Were you able to upgrade to 2016 successfully? I tried to upgrade but I lost the OS mirror raid. Would you be able to help me?

Gramps,

Thanks a million for posting links to the software for the raid and OEM tweaks.

Are there any instructions that I should follow when installing these?

I have successfully installed Windows Server 2016 Essentials on this box, and would like to get all the WD doo-dads working.

Thanks.

If you got it installed you must not need the raid drivers. I think there is a setup bat in the oem tweaks file
just extract it/all to a c:\wd folder and run it with fingers crossed or a good bckup :slight_smile:

For my 2016 installation, I extracted version 2.2.10.18 to WD in C drive and ran all the WD Apps except for WDBranding. Everything works fine, except the followings:

  1. The Audible Alerts and About page under the MONITOR tab - no report
  2. Microsoft Pinpoint under APPLICATIONS tab - does not connect at all
  3. Server Manager reports error for WD Product Config and Aft - I set those service to manual to clear up

Does anyone able to get Audible Alerts working?

I upgraded yesterday from Server Essentials 2012R2 to Server Essentials 2016, then uninstalled all the original WD bits and reinstalled from Gramps’ dropbox.

The audible alerts work for me.
The fan is running fast 1567rpm now (versus 770rpm)
The LCD service seems to die after a few hours.
I found a WD link : The LCD display and system fan acts abnormally when transmogging from Windows Server 2012 R2 Essentials to Server 2012 R2 Standard on a WD Sentinel DS series which advises “The system fan and LCD controls are part of certain WD Components that run on Windows Server 2012 R2 Essentials. After the transition, Windows Server 2012 R2 Standard provides users with the option to completely remove all R2 Essential roles. Selecting this option prevents those WD Components and services from operating, causing the system fan and LCD display to misbehave.”

Also, the site //server/connect fails … I am investigating (//server works)

I’m not sure what you do, but I did a couple of successful install - attempted to use SSD. For the mean time, I’m using stock OS disk and plan to get a spare.

I did a fresh install this way. The data on my raid remains intact, just reconnect folders afterwards.
1- burn Windows Server 2016 to a DVD
2- plug USB DVD Reader w/ Win Server 2016 DVD
3- at boot up, press Del to get into Bios
4- in Bios boot menu, select DVD, save and exit
5- upon reboot, it will ask press any key to boot from DVD, press any key
6- now you will see DVD loading content
7- *do not select upgrade, pick the other option - I just don’t see the need to upgrade
8- at this point, you probably won’t see any HD displayed
9- plug a USB drive w/ SATA Driver, like the one you can download from the previous post
10- now search for driver, go to that directory. If you don’t see USB drive, just hit back and try again
11- at this point, the HD should appears, OS 2xHD will appear as one, note the size
12- delete other partitions, install on this disk
13- once done installing, go to WD site and download current firmware, extract them in a WD folder in C drive
14- install all the app, go down the list, you can ignore Branding, it has no effect anyway and no need. note one that says preinstall, then click that first…
15- reboot, everything should work except what I mentioned in the previous post

I know it works because I have done it a couple of times. Same result every time. Good luck! Hope you find that helpful and I’m not too redundant.

What speed is the fan running Anthony?