DS5100 - 2nd boot drive will not create RAID array

I have a DS5100. I have an original AV drive, however I’ve replaced this with a WD Black and used the stock recovery to do so (so it’s the standard WD Windows image with modified Drivelist).
(Offtopic, but it does mean I’ve also created a full recovery ISO for this which applies the WD standard image - not sure why WD couldn’t offer this rather than have to issue a complete replacement 2.5 drive?)
When I add a blank 2nd boot drive I was under the impression the WD software would automatically create a RAID1 array across both boot drives. This doesn’t seem to be happening for me. The only notification I get is within the Server dashboard that a new uninitialised drive is available. I can use it as a new drive, add it to a storage space and such so it is working.

I’ve tried going into the WD RAID utility and manually creating the array, but when it tries to create the array it fails with the error message: “Error: Disk has running OS on it” (which makes sense as the OS is running).
I’ve tried to access the RAID controller screens during startup, but it doesn’t seem to be there. I’ve tried Ctrl+I, Ctrl+M after reading other posts on here but it just continues to load the OS.

Does the DS5100 not have this capability? Is there a BIOS update I’m missing to access the RAID controller prior to the OS booting? In the BIOS, I have noticed that all the SATA ports as set as AHCI rather than RAID. I changed this setting but it didn’t have any affect so I’ve changed it back to it’s default.

Would someone be able to confirm their settings - and how to access the RAID controller?

I’ve tried this on both Server 2016 and 2012 R2 but both neither allow me to create the array. For the purposes of this post I’m going to stick with the stock install of 2012 R2 Essentials running WD Utils 2.2.11.19 and forget about 2016.

Hello,

I recommend you contact WD support about this.

Thought I would provide an update on this matter, as it will likely come in useful for others. I have resolved this by my own means but it was a bit long winded to do so.

Quick version - Created boot drive RAID1 whilst using Windows-To-Go from USB.

I did contact WD Support over this and they couldn’t resolve it. The team in charge of the Sentinel support deemed my unit faulty and said it would need a replacement but as I’m OOW I was out of luck. The person handling my individual case was able to replicate my problem on the DS5100 they had access to so was dubious of the answer given but couldn’t offer anything more. As I could create a RAID on the data drives I went on to work my own solution - it’s a bit long winded but works.

As the only thing preventing me from creating a RAID within Windows was that the OS currently in use was running from 1 of the boot drives. I couldn’t get the Sentinel to boot from one of the Data drive positions, so I opted to create a Windows-To-Go USB drive based on Server 2012R2 Essentials.

For those unfamiliar with Windows-To-Go - it’s pretty much a full Windows Installation which runs from a portable USB drive. It was a manual process but fairly straightforward - just use a decent USB3 drive. Booted Windows from the USB drive, installed the WD tools (which worked, even from USB) and open up the RAID utility to manually create a boot drive array.

The downside to this is it will trash your current installation on your boot drive and needs a complete reinstall of Windows. Not an issue for me as I never set it up properly whilst trying to sort this issue out and I’ve got the genuine WD recovery on a USB drive.