Dropped my book, spins up, not recognized

I wiped my computer to put windows 7 on it and while trying to transfer my files back to my PC my My Book fell on the floor. Lock light comes on and I hear it spin up with no grinding or clicking but computer does not see it. I took it apart and connected to computer with sata and no joy. It is not recognized when I plug it into my laptop either. No errors or anything. Just nothing happens. Any suggestions? Do I need to do anything special to get it to be recognized when using sata? Because I just plugged it up and restarted the comp. I am super super super screwed. I lost everything due to the computer wipe and the fall. Any help will keep my wife from killing me. Thanks.

I am in the same boat.  I dont know what i need to do to get this thing to read.  Mine powers up spins and then cuts off.  If i push the power button on the back it will stay powered on but still nothing.  My other external HDD’s are showing up on my MAC just fine.  However, i am not real incline to pay a whole lot of money to get my info back. The price are pretty hefty when you begin calling around to get quotes and some of those companies are rip offs so beware.

Sorry guys, generally this means a trip to the data recovery center. The only thing you can reasonably do is plug it into the computer directly (taking the hd out of the plastic book casing.)

Otherwise it is very likely that a platter or head has some damage.

I dropped my 1T MyBook and it isn’t recognized.  I ran a diagnosis on it and it has numerous sectors that are bad.

Does this mean that nothing can be done to fix this? How can I recover my info?

You can try reading what info is there and available, copy it to another hard disk.

Though it sounds like a head-crash in the making. If anything can be read, do so immediately.

If nothing, then there is little we can do, I’d recommend a professional recovery service.

Thanks.  I was afraid of that.  I can’t even get an icon on MyComputer page.

I have the exact same problem, but i didnt drop mine. I also hooked it up to the cpu with the sata cable and got nothing. And this happened after using my hard drive for nearly all day. The small usb connect kept falling out of my HD while I was trying to use it, and I was getting a error messege of delay write falure…


Since the cable kept falling out the drive is probably corrupt. Get another cable and maybe you can use some recovery software to get stuff back.

i tried a differnt cable, it wont read, I tried differnt usb ports and differnt computers. I even took it apart and tried hooking it up with the sata connection inside the pc and still it does nothing. the drive spins for a minute and stops

I assume these drives are not recognized by the bios when taken out of the case and connected to the system directly?