Drop Box Is Back

For all of you guys wanting to use drop box with your EX2 go to the install app section of the EX2 GUI and you will see that WD has put it back in the App list for installation.  Let the fun begin…


1 Like


now we need ONEDRIVE!!! (have unlimited space on that one!)

how this works in this case?

just like a client in the pc (so you have the same amount of space on the account) or in a different way?

I personally dont use this, but logic dictates that you can only use as much space as you have available in your Dropbox account.  This is just another way of being able to share files amongst your friends.  I assume people using dropbox can put a file on dropbox and it will be synced to your EX2 where you can move it to another folder etc.  You can also put files in the Dropbox folder of your ex2 and it will be available to others via dropbox.

I really dont see the big deal.  Seems much easier to just give people direct access to the EX2 via either FTP, Webfile viewer, or WD app installed on their phone or PC.

Vertech1 wrote:


I really dont see the big deal.  Seems much easier to just give people direct access to the EX2 via either FTP, Webfile viewer, or WD app installed on their phone or PC.

Couldn’t agree more with this.

This doesn’t seem to work.

I installed the DropBox app and connect it with my account. However it doesn’t sync and the folder remains empty.

Even when I click “Sync Now” it only displays a brief “updating…” box and the status becomes “sync paused” shortly afterwards. Still no files are downloaded.


Even when I click “Sync Now” it only displays a brief “updating…” box and the status becomes “sync paused” shortly afterwards. Still no files are downloaded.

I have the same problem: the dropbox app is permantly in the status “sync paused”.

I have to stop the app and restart it, then synching does start again. But after sync has finished the app stops again :frowning:

I cannot trust this app!

same exact issue with Dropbox.

First - a good reason to use the Dropbox App on a WD MyCloudEx2 (in my opinion): If the disc fails / burns / gets lost / stolen - there’s a Dropbox backup. If Dropbox fails, you still have your HDD. Just an extra layer of safety. Maybe a bit overkill, but I gues it depends how important your files are, and how much you want to spent on a solution. For me, this is perfect.

Second - I had issues getting the Dropbox App to work properly as well:

Didn’t auto-sync. As someone else mentioned, the app works after a reset, so it is possible to have it working. There is just something preventing it from continuing to work…And/or something preventing it to work, even when manually pressing the sync-button. Assuming the app works 100%, it seems that as soon as the connection is established once, it fails to work a second time, or a third. Very hard to analyze with limited knowledge. Contacted helpdesk - no luck there. While discussing with Andy @ WD, who was very helpful, I realized the problem might be caused by DHCP/IP-adresses. (Even though the network drive has had the same IP all the time - it was never powered off or disconnected, nor was the router reset. Still it was worth looking into because I wanted this to work.) 

Now my knowledge of IP and DHCP is very limited, so I just did what was within my knowledge and what I could easily reverse, should it worsen things. Steps I took what made it work (and it still works):

* log out on all accounts from the WDMC2

* disconnect WDMC2 from network (leave the power on)

* reset router (if you have a network switch - no idea what step to do here then)

* reconnect WDMC2

* in the router, lookup the IP-address the WDMC2 got, and make that a static one connected to the WDMC2’s MAC-address

* disable and then enable the Dropbox App from the Dashboard

NOTE: skipping these steps and directly assigning a static IP in the current configuration might possibly not work - at least it did not for me, for reasons unknown.

After taking these steps, it’s all flawlessly working now - even through a double NAT. Did testing while changing/editing/adding/removing files directly in (Apple’s) Finder in the network drive, as well as the same on the Dropbox website. In both cases with mutiple files, it synched perfectly in two directions.

So the trick was to give the WD a static IP. Maybe that is pretty obvious to some people; not to me, and in my searches for a solution, mostly on the WD forums, I did not come across this at all. It was a lucky find. Hopefully this helps someone else as well.

The Dropbox app does not work at my device. Static IP. I also reconnected it to the network several times. :frowning:

I can’t even get to the sync phase of the dropbox app - currently it just keeps asking me to sign-in when I go to configure, and doesn’t change no matter how many times I give it permission.  

I can’t get this App to work reliably. It stops syncing and never resumes. Please WD, fix this app! Thanks.

WD Company Please FIX IT

Like others, I too have a sync problem.  I played around with the settings, and noticed the following behavior

The app on the EX2 uploads a file as soon as it detects something has changed. If this operation starts, and a scheduled download sync happens while the upload hasn’t finished, the app does not detect subsequent changes to files.  Stopping and restarting the app will most often restart the sync process.

Not sure what the solution is, this seems to be a bug in the code. I set my sync interval to 1 hour, and now at least most of my changes to the EX2 are synched to dropbox.

having the same issue, keeps showing the sign-in button.
If I check the XHR requests that it polls, the response is “true”, no other errors in the JS console.

not sure what’s going on, but either way, the app is broken.

I’m seeing the same problem.

If it takes more than the configured sync interval to download/upload and item it just stops. I’ve seen it with video files. It will start syncing one, which takes more than an hour, then it refuses to sync anything else, it just says it is up to date.

I wonder if it builds a list of files to sync, then if another (scheduled) sync starts while the previous is still going, it screws up the “files to sync” list marking them all as synced even though it hasn’t downloaded them. Subsequent syncs keep using the same list even though one or more files on it were never actually downloaded.

Of course the details of what are to be synced are kept hidden so we can’t manually fix it - a case of the user interface being TOO dumbed down.

I’ve found something interesting on this.

I had thought that DropBox had stopped sync’ing. Every time I clicked on SYNC it said “Syncing” for a short while then said “Up to date”. Meanwhile the Local Sync Folder I’d specified was STILL missing a 232MB video file.

Well, what I hadn’t noticed is that it HAD synced, but not to the local sync folder I’d specified. Even though I’d double checked it several times in the Configure section of the DropBox app, and the Local Syn Folder was still as I’d set it, my My Cloud EX2 had reverted back to the default “Public/DropBox” and synced everything into there!

Hmmm… So now I’m going to leave it at that and see how it goes.

Also having an issue with sync. Constantly in a Sync Paused state after ~30GB of files saving from Dropbox to disk. Sync button does nothing. Latest firmware installed.

Hey WD… It’s been 3 years. Is there a reason why the dropbox app sync issue hasn’t been resolved yet? It’s actually a deal breaker.

Still doesn’t work.
That’s ridiculous.