Driver Error Message: WD SES Device USB Device

Hello there,

I bought a WD My Passport Essential(500Gb) today, its working fine, but my OS shows me that " WD SES Device USB Device" is not installed and may not work. (Code 28)

My OS: Win7 x86

Greetings Philipp

1 Like


Right-Click the WD SES Driver in the Device Manager & Left-Click ‘Update Driver’.

Choose ‘Install from a specific location’.The SES Driver is in the WD Smartware VCD within the Folder ‘Extras’.



i have the samentrouble but my passport  is 250 gb and my kind of windows is 7 home edition and i don’t know if i can follow the same direction

Follow the steps below:

. Right Click on My Computer/Computer, Select Manage.

. On the New Screen, select Device Manager and then look on the WD SES drivers with yellow mark,

. Then Right Click on it, and select Update drivers.

. Now select WD Smartware and then select WD SES drivers under Extras.

1 Like

Pass the WD SES folder to the Windows\system32\drivers, i did that and it works ok without asking anything.

mohammedw88 and JCF2009,

What if you removed the VCD from the drive?  Will the steps you outlined above still work?

Yes, i use mine without the virtual cd and it works fine, at least for the elite version, but you could try it. Copy the driver folder to windows and then disable VCD, cycle power the portable drive, connect again and if it asks for the driver browse for it.

I am getting Access is Denied, when I try to install the driver. Also when I run   WD Smartware.exe it fails with 25 seconds to go.

have you try on others PC? need more detail.

I have a Dell Inspiron 510m laptop and am using Windows XP Home. I could try on another laptop but if I plug it into another laptop and it works OK, surely it would then backup all the data on that laptop. And I don’t want it to do that.

Another clue to the problem is that I have had problems with installing any new USB devices for a while. When I plug in a new USB pen, instead of it just installing as it should, I get the Hardware Update Wizard appearing over and over again, one on top of the other. Eventually I manage to cancel all these occurences and the USB install with errors. Then if I go into the Device Manager, I can see the USB device with an exclamation mark by it. If I then reinstall the driver from there it installs OK.

can you PM me with email? then we can chat online. and have you check others USB port on DELL laptop? does it works fine before? it’s seems software have problem. external drive sure works fine.

How do I PM you with email? What is PM?


search have my contact

I’m sorry but I don’t understand the above.

People, what do you think about that the new My Passport drives needs drivers for “WD SES Device USB Device” to work !!!???

yeah. need install driver. just continue click next will be fine.

1 Like

I have been having a problem where Windows 7 will fail to boot when the Passport drives are plugged in during a cold boot. (Booting just freezes - and on re-boot, Windows 7 auto repair fails to fix the problem, but normal booting without drive is fine.)

(Edit : Please note that I am not trying to boot from the external WD drives. I am trying to boot from my main hard drive, the WD drive only contains data and no trace of any OS, and that USB devices are configured BELOW IDE devices in the boot sequence in BIOS)

Anyway, back on topic, …

I tried to fix this problem by coming to the WD web site and searching for software/firmware updates.

I downloaded and installed the firmware update. (Apollo 1607E Firmware Updater v2.003 (

Then downloaded and installed the utility to hide the WD CD which I have never needed. (WD SmartWare Virtual CD Manager for Windows-v1.0.7.4)

All seemed fine, but noticed that a driver has failed to install in my Device Manager for “WD SES Device USB Device”.

Windows Update can’t find it.

The advice on this forum says search the Extra folder in the ‘CD’ drive - but I have now hidden it.

Couldn’t see a separate download for it.

How on earth do I now install the driver from the drive that is now hidden?

Where can I simply download a stand alone version of it?

What does SES stand for? i.e. what is this device/driver for anyway?

SES stands for SCSI Enclosure Services, it let communication between the enclosure and hte SCI initiator. It can access information like power and cooling. It may affect the encryption feature. I can provide you with the driver if you want or google it.

OK i have done this to install the missing driver

Go to Device Manager

Right Click on the WD SES with the Yellow ! on it

Go to Update Driver

Browse my computer for driver software

Then the driver should be in this folder C:\Program Files\Western Digital\WD SmartWare\WD Drive Manager\WDCSAM

After doing that it should install fine!

This was done on Windows 7 64Bit OS

If you need more help what you could do is search for one of these files in the program files folder and see were they are…once you find then that is the location of were the driver is.




Hope this helps!

Is there a way to use the drive without installing the driver? Problem is that I don’t have administrator access on the computer, so I’m unable to install the driver. I don’t have problems with other external harddisks before though.