Drive Won't Mount - 2TB MyBook Studio Edition II


I have two externals – both 2TB Western Digital My Book Studio Edition II – purchased January 2011

I will call them the Good Drive… and the Bad Drive.

I’m on a MacPro running 10.7.4

The Bad Drive has a slow flashing light on the front (lights up around every 4 seconds).  I’ve tried to find out what this means on WD site, with no luck.  

The Bad Drive will not mount via Firewire 800, and doesn’t even appear in Disk Utility.  If I daisy-chain the Good Drive through the Bad Drive’s FW-800 port… the Good Drive mounts just fine.  Then the activity light on the Bad Drive starts flashing faster, like it’s trying to do something.  But it still does not mount, or appear in Disk Utility.

Any suggestions much appreciated.

I’ve rebooted, swapped cables, tried everything.  The drive is not making any odd noises.

Try another cable and connect direct to the Mac

you can try usb as well

1 Like

Turned out to be a failed drive.  Fortunately I had recently made a complete copy.  

Western Digital replaced the drive very quickly under their amazingly long warranty on these drives, really impressed with both the service, and the warranty.  

First Western Digital drive I’ve ever had fail.


WD warranty service has always worked like a charm for me as well