Drive Stopped Sleeping

My MyCloud 3TB drive didn’t spin down when I first installed it and I attributed that to it indexing the files I had backed up. After that, I determined that it would indeed sleep, but only if the cloud feature was disabled.

For the last few weeks though, it spins 24//7 and does give off a little bit of heat. I continue to have the cloud feature disabled and overnights I have shutdown the 2 laptops that connect to it. Still it spins all night without any traffic.

This latest firmware left out the shutdown functionality and I have to wonder whether the drive sleeping functionality has been hampered as well. How can it not spin down without anything addressing it?

Is this a gen 1 or gen2 MyCloud? If you can SSH into the MyCloud check the /var/log/user.log for any repetitive messages.


First the v2.x My Cloud firmware not having a shutdown option is a well known issue that for what ever reason WD hasn’t chosen to fix since the v2.x firmware versions were first released to market.

Do a subforum search for “shutdown” and you’ll find several threads that discuss methods of shutting down a Gen 2 v2.x firmware My Cloud using the WD Quickview App or SSH. Here is one such recent thread:

Second, the sleep issue is well discussed on this subforum. Do a subforum search for “sleep” and you’ll find numerous threads on the issue with various methods that attempt to have the My Cloud sleep more than a few minutes. Here are just a few recent threads that discuss various workarounds: