Drive stats stopped reporting free space available

Recently the drives stats page stopped reporting the free space available on the drive. I’ve tried rebooting the drive through software, and more recently shutting down, unplugging , and powering the drive back on. Neither has solved the issue. Any suggestions as to how to get the home/statistics page to start reporting the free space on the drive again?

I am on Firmware: v04.01.02-417. I have about 900 videos, 18,000 music tracks, 19,000 photos, and 56,640 things listed as other. I am currently waiting for the content database to rebuild.

Hello,

I recommend you contact support directly.

Contact WD

1 Like

so I called tech support. They first had me try to reset the system with a paper clip in back. quickest option but only removed my static IP address and reset the IP to DHCP. No change in the free space reported in gui. 

They next had me do a “system only” restore from the factory restore in the gui. took about 20 miutes. Again reset my IP and changed some share permissions that made it hard to get windows to see my shares. restored the “group” permissions to the Public folders through chmod command and ssh. Still no free space reported. At this point the support person told me that I should transfer all data off the drive, do a Quick Restore, which will wipe data, and see if this resolves it.

If not they are holding the ticket open. According to support, if this doesn’t resolve it, the next step is for me to contact them. They are going to mail out a new drive and then I migrate the data back.

Still not sure what is happening. I can see the space if I do df -h \DataVolume from ssh. So I know the drive is fine and reporting the statistics. Appears that the routine that collects the data from the drive and passes it back to the gui  software is not functioning correctly.  I’ll keep you posted.

moved all personal data off the drive. did a System Factory restore-> quick restore. Once light on front was solid again, I powered off unit, waited 10 seconds and powered it on again. System has returned to the initial “out of box” configuration. Capacity -> free space output is now restored. 

Still not sure what corrupted the routine that supplies free space to the gui? Would be nice if this could be incorporated into the Factory Restore-> system only restore, that way I wouldn’t have to spend the time to empty the drive of personal data.

Empty drive initially reported free space and began functioning again as normal. I copied about 4Gb of data to the drive and it began operating as before and stopped reporting free space. I re-contacted WD support. We tried a reboot, no luck. He mentioned that it appeared that the firmware was up to date but was not functioning correctly. I asked if it would hurt anything to try to reload the firmware.

I downloaded the latest firmware and did a manual update to the drive. Once the drive re-booted it began reporting free space again.

I am now copying more data to the drive to test if this is a permanent condition/fix. My next move is to have WD replace the drive.

All appeared noraml until I reached about 1.5 Tb. Then the free space stopped reporting again as before. This is pretty concerning as I bought a 6 Tb drive and would like to use more than 25% of it. I recontacted WD Support. They are of the opinion that this must be a bad drive and would like to replace it. I’ve now done a full factory restore to remove the data that I have written to the drive and am waiting for the new drive to arrive in the mail. 

Anything off with the SMART readout from the drive?

smartctl --all /dev/sda

I wonder if the chmod changes could have interferred with the GUI display app recognizing the data? Did you make any other changes?

You said you could see the data from SSH and linux. Can you see if from another PC (Mac or Windows)?

And…three other people reported something that appears to me to be the same symptom:

http://community.wd.com/t5/WD-My-Cloud/Capacity-on-Dashboard-is-Blank/td-p/841817

So I am not sure that RMAing the unit will solve it…

Chiming in to say that I too have this problem. Capacity doesn’t show up anymore. And I don’t have much on my 3tb MyCloud yet (maybe 200gb right now, at most).

Received the replacement my cloud from WD. It arrived with firmware version 4.00.01-623. I set it up the same way as I did the old drive, static IP, ssh on, turned off iTunes server, DLNA server, and the firmware auto update as I suspect the firmware update to have created this “drive free space reporting” issue.

I did a full factory restore on my old drive with the latest firmware through the gui to remove all my data and prepare it to be shipped back to WD. I decided to try an experiment as I had 30 days to return the old drive to WD. I set it up on it’s own static IP with the same options turned on so I can monitor activity side by side. I wasn’t sure if I was just pushing data at the drive too fast and not giving the indexing process on the mycloud enough time to complete it’s scan. So I then copied 100 GB of data to each using the Windows copy/paste from a common PC. Both drives behaved the same way and displayed drive statistics as expected. I then used the same method and copied 10 GB of photos to each, again no difference, all good. I then copied 300 GB more of data to each. At this point the drive on the old firmware continued to behave as expected, but the drive with the new firmware stopped reporting statistics and displayed the dash(-). I waited until the scanning page showed that it was done scanning for file types and idle, but the drive with the new firmware still would not display drive statistics.

I then turned on a backup program, syncback, to move the bulk of my data to the my cloud with the old firmware. I have about 1 TB more to move. I continued to monitor the drive then left it to work in the overnight. I checked it this morning and all the data has moved. The drive statistics are up to date. I checked the drive with the new firmware, still just a dash(-) or free space.

I read the release notes for the latest firmware. It only mentioned this repaired an issue with ATP. I don’t use the iTunes server or time machine backup. I can’t see any of the release notes for the previous firmware versions, but at this point my drive is working for what I need it to do so I am inclined to leave it and not update firmware as I think it is something in the latest firmware that is corrupting the database, I just don’t know how to prove it. I am not planning on updating irmware until forced to do so.

Sorry, I did follow the suggestion and run smartctl --all /dev/sda. No errors were reported against the drive.

I also have the same problem, not getting any capacaty stats on the dashboard, only a “-” symbol. I am pretty sure this has something to do with the latest firmware as the problem occured after updating to the latest firmware.

Just one of the endless problems with the WDMYCLOUD and its supporting software / apps

I’ve waited a couple of weeks to repost. I’ve done more research and found that I wanted to update the firmware to at least 04.01.00-408 as it contains a fix for the shellshock bash bug. I already have a second copy of the data on another system so I was willing to attempt the firmware roll back. I downloaded the firmware and did a manual firmware update through the GUI, except I wasn’t paying attention and updated the drive to 04.01.02-417, which is the firmware I am suspicious is creating the free space reporting issue. After an “oh **bleep**” moment, I tried to manually “roll back” the firmware, which errored out. I then found an instruction on the forum to change the contents of the /etc/version file to a number lower than the version I was trying to roll to. This then allowed me to manually roll the firmware back to 04.01.00-408 through the GUI.The good news is that I was able to do all this firmware “changing” and never lost a bit of data.

After the roll back I nervously, rebooted the drive. I have the twonky server and itunes server turned off. I also have the time machine backups turned off, so I’m only using the drive as backup storage with a static IP address. Following the reboot, the drive correctly reported the free space and has operated normally since.

I have added another 200-250 Gb to the drive over the last 2 weeks since the firmware update and am still getting drive free space statistics as I would expect.

Not sure if the firmware roll back constitutes “breaking the warranty” so please do your research and proceed at your own risk. I hope this may help others with this issue until WD can figure out what broke the freespace reporting routine between firmware 04.01.00-408 and 04.01.02-417. 

I’ve also changed my feeling about updating. I used to roll up the newest driver and firmware updates, presuming that they were backward compatible and would only include fixes to current or future issues. This experience has changed my mind. I will only update if the firmware includes specific fixes for problems I am experiencing.