Drive shows on Desktop but content missing unless I unplug and plug the drive


I have a Mac 2012 model with MacOS Sierra 10.12 installed on it.

I recently bought a 4Tb drive as I try to keep my media seperate from the main computer. My problem cropped up recently where the drive still shows on the desktop but when I click on it, finder will show nothing. This is after the computer has not been used for a while and may have gone down to sleep mode. I need to unplug the drive and replug it in and the contents will show up again with no issues. I do have another WD drive attached to the same computer and it does NOT have the same issue, so it seems like it is only with respect to this 4Tb drive. I have tried running WD Drive utilities on it for the Mac and it shows the Smart has passed and that the drive after a quick scan at least is ok.

I was wondering if this is a firmware issue? Or could it be a MacOS Sierra issue since the drive is a 4Tb drive. the 4Tb drive is formatted with HFS format.

Any clues would help. Thanks


I’d recommend double-checking the sleep behavior settings for the new unit in order to ensure it matches the behavior of your older unit. You can do so using WD Drive Utilities for Mac.

Find the Refresh feature of your computer’s Finder or File Explorer and click on it. This can bring back “missing” drives.

Thanks. But the drive does not disappearon the desktop. It is when I double click on it and then the contents of the drive will show up blank. 0 files but it shows 2.84tb is left. What I did was to reflash the firmware and it seems to have resolved the prpblem.

Get Outlook for iOS

Hi Mike
i did check on it and turned it off and rebooted but it did not resolve the issue. What I did was reflashed the firmware of the hard drive and it seemed to have resolved itself. Thanks.

Get Outlook for iOS

Good to know. Thanks.

I’m having the identical problem with my brand new 4tb My Book. Interestingly the problem has also spread to my 2tb My Passport Ultra as well, which was running fine for over a year as my main Time Machine back up until I decided to use the new 4tb for Time Machine and the My Passport to store media files. Could you explain how you reflash firmware as I would like to give this a try but I’m not familiar with the process.



If you are using the mac, download the program wdfirmwareupdater for the mac. Then follow the instructions after installing it. Basically make sure only one wd drive is attached to reflash the firmware.

Also make sure to turn off the sleep option using wd drive utilities for mac.

So far everything is ok after I did both

Thanks for the info. Gave this a try but wouldn’t work.

I have since deleted the WD Utilities app and I’m using time machine to back up internal hard drive to the external 4tb and this has worked so far. I also completely erased the 2tb media drive and I am going to again try to transfer my pictures, music and videos to this drive, and have it back up to time machine. Hopefully this will work.