Drive shows 3.9TB of files allocated, but files + folders are gone

My 6TB Cloud drive has worked like a dream. I have bragged about how great it is and recommended it to many people.

I can access the drive and some folders are there (shared photos, shared music) but shared videos is only showing items which were recently placed on it.

The UI shows that the files are still there but cant quite figure out. (see screenshot )

Also, the drive is doing R/W the whole time I turn it on. I thought perhaps it was cleaning itself up and hoping that it would fix itself overnight. after 23h of letting it run, I decided to shut it down (via the software).

Any help would be appreciated.



How are you accessing the drive? Windows File Explorer, Mac Finder, WD My Cloud Desktop, WD My Cloud mobile apps,

You can access the My Cloud Dashboard and check the Shares page to see if a Share has changed in size if the files were moved to another Share (like a Private Share that a User doesn’t have permission to access) by accident.

One could also use SSH to access the root level of the My Cloud and view a folder/Share’s contents to see if possibly the missing files are actually still there.

I have accessed it via iMac as a network drive. the screenshot I sent is from the mac of the UI from WD.

Also, I have looked at it via my cloud (iphone app) and same situation; folders are missing.

SSH. how do I do that?

You can do an internet search on SSH to learn what it is and how to use/issue commands using SSH. One enables SSH within the My Cloud via the My Cloud Dashboard > Settings > Network > Network Services.

you are requesting me to make ssh workable, yet this may void my warranty. Also it warns here that you best know what you are doing in Linux to issue such commands. I don’t.

you basically are telling me to go learn chinese, but If I say something wrong, my computer is screwed. :wink:

without SSH access, is there any other way to get the HD to find the files – which it obviously sees – to be recognized accordingly?

Please note that this is a use to use support forum. The message one receives when activating SSH is a generic warning message WD put in there to warn users. Far too often users have issued certain commands that are not compatible with the My Cloud firmware (like issuing the apt-get command) and they’ve bricked their My Cloud or deleted firmware files/folders. One can use non destructive SSH terminal commands like LS or DIR to list the contents of a directory. One can issue commands like cd <directory name> to change to a sub folder. Point is one can use SSH to access the My Cloud at the OS/Firmware level and potentially see things you may not see using Windows File Explorer or Mac Finder, or other methods of file access.

This link explains in general terms what commands one can use once connected to the My Cloud using SSH to list the directory and change a directory:

Or one can use a graphical user interface SSH program that makes accessing SSH much easier. WinSCP is such a program for Windows (, do an internet search for similar programs for Macs.

Other troubleshooting steps. Enable FTP through the My CLoud Dashobard and see if the files are still not showing using an FTP Client (like FileZilla - Reboot the My Cloud. Perform a 40 second system restore using the reset button on the back of the My Cloud. No user data is (supposed) to be affected by performing a system reset or system restore using the back reset button.

Bennor, Ok, you got me off of the ledge. :grin:

I was unsuccessful logging in with FTP, but with SSH it worked, and I found my “other” 3.9tb file. here’s what I see;

WDMyCloud:/shares# ls -la
total 3900
drwxrwxr-x 7 root share 4096 Oct 17 07:15 .
drwxr-xr-x 6 root root 4096 Jul 20 2015 …
drwxrwxr-x 3 root share 4096 Oct 19 15:10 .wdmc
drwxrwxrwx 2 root share 4096 Oct 19 15:34 .wdphotos
drwxrwxrwx+ 6 root share 4096 Oct 19 15:07 Public
drwxrwxrwx+ 2 root share 4096 Jul 20 2015 SmartWare
drwxrwxrwx+ 2 root share 4096 Jul 20 2015 TimeMachineBackup
-rw-r–rw- 1 www-data www-data 3947520 Aug 30 2015 groupings.db

I did a quick look at groupings.db and it definitely has the missing file structure I am looking for. ok, what’s next?

4 second reset. just read what it’s all about. but then I saw the 40 sec reset but it didnt explain what that did. what difference would that make ?

Yes it does.

But you want this:

The link I posted above earlier today as well as the same link Cpt_paranoia posted explains the difference between a 4 second reset and a 40 second restore.

The 4 Second Reset will reset the following:
Admin Password (No password by default)
Network Mode (Default = Dynamic Host Configuration Protocol (DHCP))

The 40 Second Reset, also known as System Only Restore, will reset the following:
Admin User Name (default = “admin”)
Admin Password (No password by default)
Device Name (default = “WDMyCloud”)
Remove all Users except Admin
All Share permissions (default = Public)
Automatic Firmware Update (default = off)
Network Mode (default = DHCP)
Remove all Alerts account association (default = not configured)
Mobile app account association (default = not configured)
WD Sync association (default = not configured)
Backup jobs (default = not configured)
Safepoint jobs (default = not configured)

As previously explained no user data/files should be affected by a 40 second system restore.


also, my drive is Read/write the whole night. I am not accessing it. thoughts on what it’s doing? resetting the defaults with the 40 second restore may be great, but how do I get the 3.9 tb file back into a tree?

A 40 second system restore sometimes fixes weird issues with the firmware including possibly resetting the File Server that is the interface for file access. A system restore could trigger the My Cloud to rescan the file system there by potentially fixing what ever issue is causing the files to not be seen.

On a side note if one used special characters for the file or folder names its possible the OS or the My Cloud apps/ are not showing the files/folder. For example if one uses a period as the first character for a folder certain OS’s will consider that a hidden folder and normally not display it to the user.

If one accesses the My Cloud using SSH they can dig through the Share folder locations to see where their files/folders are. For example on a v4.x firmware My Cloud if one accesses the /DataVolume/shares using SSH and then issues the command: du -h they will get a listing of all the folders (and their sizes). From there one can see if their folders have been moved and if they have special characters that are causing them to be hidden. When doing a du -h you may see a number of folders that for the OS/firmware and not generally accessible (other than by SSH) to the user.

This command will give you the amount of disk space used by each folder in the /shares folder.
cd /shares
find . -maxdepth 1 -type d -exec du -hs {} ;


I assume I should keep it disconnected from the LAN?

What? It’s a NAS; a Network Attached Storage device. How are you going to access it if it’s not connected to your local network?

Have you found your files yet?

I was thinking of cutting the Lan When doing the 40 second reboot.

I haven’t had time to issue the command yet. Wife and kids :slight_smile:

update; turns out my files were deleted and in the trash can of one of the computers I have accessing it. Files are now back online, but WD Cloud still does not recognize the missing files. The content scan still running for past 4 hours.

any thoughts?

status quo. WD UI shows that it is still scanning the media. … but does it matter?