Drive on USB 2 powering off automatically after period of inactivity (never did on old WDTV Live G2)

I just got a WDTV Live Streaming the other day.  I have the latest firmware, and I have 2 self-powered hard drives plugged in to USB ports 1 and 2 (one for TV shows, two for movies).  Both hard drives are Seagates and have been set to never power down (I confirmed this setting has not changed).  

The power on USB 1 always stays on, no problem.  The green light is always on, etc.  However, after 30 minutes or so of inactivity (I’ll try to get a more accurate time), the power on USB 2 (my movie drive) shuts off.  Green light off, etc.  If I try to use the network to copy a file to the drive while it’s powered off, my whole computer freezes for a few minutes (if I’m lucky) while it tries to power-up the drive.  

These are the same two drives I had plugged in to USB1 and USB2 on my old WDTV Live (G2) and the green lights were always on, neither drive ever powered down.  That’s still the same with USB1 on the new WDTV Streaming.  

I have the screen saver turned off, so that’s not it.  I don’t see any power management settings, and if there were any I’d expect them to treat USB1 and USB2 the same.  

I never had this problem before with my old WDTV, and it’s really annoying.  I don’t want either of the hard drives connected to the WDTV to power down.  Anyone else experience this?  I’m assuming this is a bug.


It is about 30 minutes, though I haven’t timed it to the second.  And not only does the drive go off after inactivity, it even shuts off after the video file has been on pause for 30 mins or longer.  When I hit play to unpause it, it will continue to play whatever was in the buffer, then cut off and go back to the menu screen.

This was the final straw.  I’ve already gone back to my old WDTV G2, this new WDTV Streaming will be returned.  There are a few other annoyances I figured out how to deal with or fix (metathumbs replacing folder.jpg, stuff like that), but this hard drive power-loss issue is completey unacceptable.  

It all works fine now that I’ve replaced it with my old WDTV… unbelievable.  The only feature I really like on the new WDTV “streaming” is the iPhone remote control App.  I wish that worked on the older WDTVs.  

have you tried switching the HDD’s? like puting the one that powers down on the other USB port and same for the one that doesnt power down? also try different USB cables.
it may be possible you have a faulty SMP but it also could be a number of other things.
you could also test rolling back the SMP’s firmware to see if its something in this newest release.

Yes I have tried switching drives.  Not only that, but it seems after a half hour of being paused USB 1 sometimes shuts off too.  I am using the same USB cables I’ve always used, that work with my older WDTV Live.  

I think this newest WDTV, unlike the previous models, is just built much more cheaply and is ultimately a piece of **bleep**.  It feels junky, it looks frail and cheap, and based on feedback and other people’s problems it must have been rushed out without adequate testing.  I’d love to know whether it’s made at the same factory with the same quality internals as previous models.  I bet it’s not.

Constantly frozen “updating media library” (which I finally turned off) is another huge issue I have with it.