Drive not showing up in Network under computers

#1

This drive seems to have got worse and worse under windows 10. It hardly ever shows up as a computer in my network yet all computers on the network can access it via its static IP address and through the browser. It used to work perfectly under windows 7. Whats the point in a drive that isnt instinctively available via file explorer?

Very frustrated still 12 months on with this unit - every firmware release seems to make it worse!!

#2

See the tacked first thread of this subforum that provides several potential options to solving Windows 10 issues with the My Cloud:

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

#3

It used to work perfectly under windows 7
This drive seems to have got worse and worse under windows 10

Do you think Windows 10 might be the problem…?

#4

I had no problem with the My Cloud showing up under computer or network. After my
laptop updated the latest Microsoft patches. The only things showing up under computers or network are the two windows 10 systems.

RAC

#5

There’s no SMB option setting option with the latest firmware.

Personally, I would have expected the latest firmware to sort out any windows 10 problems - clearly I expected too much. This box should work in windows 10 without any tweaks necessary - it doesn’t

#6

For those who have the v2.x My Cloud’s there is apparently an SMB option in the Dashboard. For those with the v4.x My Cloud there is not. Instead for v4.x My Cloud users they can use SSH to edit “smb-global.conf” on their My Cloud to change the SMB version/level as explained in the link above.

As explained in other threads, the November update for Windows 10 caused problems not only with the My Cloud NAS but with other manufacturer’s NAS drives. The link to the tacked thread/link above offers workarounds for certain Windows 10 issues.

#7

Ive used or am using all of those various options already for Windows 10.

I expected the recent firmware update to fix it.

#8

install the mc_windows_setup
run the wd my cloud public share
now on the network line you have the ip of your NAS. click this, and your shares are shown, and you can map them as a drive number.
you can now copy this address and set it in on screen as an icon.
if you need to make changes just click this icon and your shares are shown in explore.
hope this help.
BTW it is not a wd error but truly a windows 10 build error

#9

can you tell me what mc_windows_setup is and where I can download it?

#10

Have you tried any of the steps detailed in Method #6 in the link previously provided to change the SMB settings either in the My Cloud or on the Windows 10 PC? In all instances on my end when Windows 10 doesn’t show the My Cloud under Computer, changing the SMB setting solved the issue.

#11

There is no need to download and install WD software. One simply needs to know the IP address of their My Cloud. That IP address can be found either via right clicking on the My Cloud icon listed under Media Devices and or Storage under Network in Windows File Explorer, or one can log into the My Cloud Dashboard navigate to the Settings > Network page and see the IP address listed under Network Profile, or via one’s router/gateway’s administration page that lists DHCP clients. With that IP address one can use it to open the My Cloud via Windows File Explorer by putting in \\<ip address> into the Windows File Explorer address bar.

Work around the share not shown on windos 10
#12

this is the setup software for the cloud-
http://setup.wd2go.com/?mod=product&device=mc&language=en-US

#13

Oh I see - yes I know that - thats what Ive had to do for the past couple of months