Drive not recognized, Win 7 32-Bit, RC1

My 250 works perfectly with two other Win 7 32-Bit RC1 systems here, but on my newest one, is not being recognized for some reason.  When plugged in, the system never loads the device, nor does it show up in Explorer.  Both of the other systems were updated from XP Pro > Vista Home Premium > Win 7 RC1; however, the system in question has a clean installation of RC1, no prior versions were installed.  This system is also running two 500G WD SATA2’s in a RAID 0 array, the others, one one IDE, the other on a SATA drive.

I’ve tried every port on the system, a total of 10 all told, and none of them will see the drive, but other USB devices work just fine.  I am thinking that it either has to do with the clean install, perhaps there was something present in the older versions that isn’t present in the newest install, or it may have something to do with the RAID array in my new system.

Any advice or suggestions would be greatly appreciated.  I use this drive quite a bit to transfer files between work and home, and for game backups.  No ends of annoyance to my wife with using her system to transfer my files via Home Group networking.  :cry:

1.  If you have NVidia chipset, try below.  It is specific to RC1 issue with Win7.

2.  updated from XP Pro > Vista Home Premium > Win 7 RC1;

Hmm, I my personal opinion it is better to go clean installation as previous OS leaves many residues.

   The system that is giving me the issue is based on an ASRock M3A785GXH/128M motherboard, which has the AMD 785 Northbridge, and an ATI SB750 Southbridge.  This system is running Window 7, RC1, however, it is a clean installation with no prior OS, on a RAID 0.  The systems that the drive is working on both are running Window 7 RC1 as well, however, both of these systems have been upgraded from XP Pro > Vista Home Premium > Window 7 RC1.  Perplexing, to say the least.

   I’ve tried all of the motherboard USB connectors on the I/O panel, as well as the four additional ports provided on the case with the same results.  The drive sits there, power LED is lit, and pulsing, and I can hear the drive running, but, the system never notifies me that it is loading the device, nor does the drive show up in Explorer, or under anywhere else it should.  Works perfectly everytime with the other two systems.  The OS is fully patched and updated, and the mobo drivers are the latest that are available from the manufacturer - I used the ones on the CD, and double checked the website, no others are out to date that I have located.

   Beats me.  If I had to make a call on this one, I’d say that there is some driver issue with the SB750, but so far, I’ve turned up nothing pertinent in my searches there.  Either that, or I have invoked the ire of the Bit Gods…  :wink:

i have the same problem, but my new PC is windows 7 with 64-bit , Gigabyte motherboad with i5 intel chip. 4G ram.

I tried to use the like to fix the problem. it said it is for 32-bit.  What should I do with it?