Drive not accesible


#1

This just happened?

I tried to open my external drive and it says X:  is not accesible.  Access is denied.

I tried to run check disk - The disk check could not be performed because Windows can’t acces the disk.

I opened Computer management, then storeage, disk mangement - and it shows up?  But i still cannot access the drive?

Someone help please…


#2

In disk management does it still have a drive letter? If not give it one. While in there check to see if it’s online if not change it. Here is a trouble shooting link too  http://community.wdc.com/t5/My-Passport-for-PC/System-will-not-read-this-Hard-Drive/m-p/117846#M3739 see post 8

Joe


#3

Joe,

Well I did some searching/googling and I spoke to a friend that told me to look at the owner tab.  He said it was weird that under “My Computer” it was showing up as a blank disk - but under administrative tools it was showing up with the data (or Normal)

Turns out that it had the “Administrator” listed as the owner - not my profile, which has administrator rights???

I do not know if this is due to a recent windows 7 updates or the fact that I installed the Western digital updates:

The following updates were installed for windows 7

Update for Windows 7 for x64-based Systems (KB976902) 16 Jan

Update for Windows 7 for x64-based Systems (KB2454826) 16 Jan

Windows Malicious Software Removal Tool x64 - January 2011 (KB890830) 13 Jan

Definition Update for Microsoft Office 2010 (KB982726), 32-Bit Edition 13 Jan

Security Update for Windows 7 for x64-based Systems (KB2419640) 13 Jan

Apollo 1607E Firmware Updater v2.018-v2.019 (1.0.8.6).exe 16 Jan

WD SmartWare Virtual CD Manager for Windows Web Release-v1.0.8.3.exe 16 Jan

WD Software Upgrader 16 Jan

I really had not tried to access the drive between the 13 and 16 Jan installs – but I cannot say it was one or the other – While I am leaning towards the Windows updates……

Here is the weird part – now I have “locks” showing up on all the folders on the drive – and it renamed it to Local Disk?

I can access all my files - But it seems weird – the lock icon on all my files???


#4

The sharing/permissions in Vista and Windows can be a royal pain on many things. On my home network there are 2 XP boxes and 2 Windows 7. I spent a long time getting one of the XP boxes to ues the printer hooled to my Windows 7 desktop the others weren’t any problem.

Joe