Drive Manager v3.1.0 shows v2.3.1

Hi there,

I’m preparing my system for the upgrade to Maverick. One step on my list is to upgrade the WD Drive Manager software to its latest version, after some issues have been found on Apple’s new OSX version.

My system is still on Mountain Lion v10.8.5, the installation went pretty fine, a reboot of the system finally finished the Drive Manager upgrade. But then I was really surprised - the version shown in the bar is 2.3.1 instead of 3.1.0, what I expected. My question out to the community: could it be, that on 10.8.x this application works with a lower version and might be using a newer version when the upgrade to Maverick has been finished? Or do I have to reinstall the Drive Manager once again after Maverick has been finished? I’m really somehow confused at the moment.

Thanks in advance, regards, Thomas

You can install the latest version of the software once the OS has been upgraded.

Please follow the steps on the link bellow.

WD Drive Manager needs to be updated on Mac OSX 10.9.X (Mavericks)

Same by me. I deleted everything from WD drove system down anup. Did the upgrade to mavericks an installed again Drive Manager v3.1.0. What happend is still shows v2.3.1?? So whats wrong here ?

Again used the WD uninstaller and did the same prcedure again and nothing helped so far…Im confused need help please…  Bildschirmfoto 2013-12-29 um 13.39.02.png

for mosesontheweb


Also for me it’s the same. I’m running ML 10.8.5 but I’m able to see v2.3.1.

Did you update to Mavericks to 10.9.1? Any problems?

So, to have the new version of Drive Manager (v3.1.0) you should migrate to Mavericks, right?

Thanks in advance. 


Yes I have upgraded to mavericks and have actually no problems, but the newest update didin’t work for me at the moment. Hope they’ll fix it soon !!

regards Marc


Thanks for the reply.

So, did you update to Mavericks first and then the Drive Manager or viceversa? It seems that the DM needs to be installed on Mavericks running.

Are you running the latest of Mavericks? 10.9.1?

Thank you.

I did it on ML 10.8.5 and see v2.3.1. I tried to use the uninstaller, checked Library for any WD Drive Software, shut the system down, installed the new version again but still was v2.3.1.

Then I did the update to 10.9.1 (hoped it will then work…) and still showed v2.3.1. Did the same procedure (tried to use the uninstaller, checked Library for any WD Drive Software, shut the system down, installed the new version again but still was v2.3.1). So thats the final stand for now and still got fear if the data will be lost or not …

Tired of uninstallations and installation of the Drive Manager… still shows 2.3.1. At least confirmation needed if it is expected to show v2.3.1.


What OS are your running? Thanks.

Same here I have tried all suggested ways, is there any hope WD will fix this? Anyone, WD?

This is the message I’ll got from WD today:

Dear Mr …

Thank you for your patience.

We have received confirmation that our technicians are aware about this issue and working towards the resolution. At the moment we don’t have the exact date when this issue will be fixed. 
We understand that incorrect identification might be confusing and we are truly sorry about that.
However there is nothing to worry about as the version that you have downloaded and installed actually is v3.1.0.
This issue will be fixed with future firmware update.

We are sorry for any inconvenience that might have been caused by that situation.


So everything seems to be ok :slight_smile:

1 Like

Hey, sorry, that I wasn’t here for some time. Nive to see that I’m not the only one who is slightly confused by this wrong version indication.

According the latest message from muddyblue it seems to be pretty ok to go for an upgrade to Maverick when used 3.1.0-14 installer which shows v2.3.1 in the driver information. :slight_smile: Nice.

But why the f**k is noone able from WDC side to propagate this information publicly? This is somehow bad support and bad for the company image as well to leave their customers in confusion.

Regards, Thomas


Just finished my 3rd call of the day with WD Level 2 Tech Support regarding this issue. I’ve been toying with this v.3.1.0 VS v.2.3.1 issue since they released it.

Today… the tech support told me that v.2.3.1 that appears in the version of the newly installed software is the most current version of WD Manager. I asked why the download link title is v.3.1.0 while the software stays v.2.3.1. He said it doesn’t work that way (thought this is a first for me hearing this). He said to think of the dowload title of v.3.1.0 as a “shopping cart” that goes to the “store” and picks the correct version of software off the “shelf.” In this case, the version sitting on the shelf that is correct, he said, was v.2.3.1. 

This seems like a fuzzy explanation to me. I asked that if this is in fact the case, is v.2.3.1 a version that is now free of conflicts with Apple OSX Mavericks? That has been my biggest concern (as has been for most people). He said it is free of conflicts with Mavericks (but I’m still not feeling certain about the answer). 

On top of that I mentioned that there are many concerned people on the WD Community message boards discussing the same issue of the two different versions (3.1.0 VS 2.3.1)… and that it would be great if WD could put out a statement to everyone, confirming where it all stands. He said he would try, but there were no guarantees. I’m not sure why WD wouldn’t want to do that immediately. 

So that’s what I was told. I’m still not feeling very comfortable. I’m really ready to get my update to Mavericks installed, but I’m fearful of a conflcit occurring between it and my WD My Book II drive. 


1 Like