Drive letters disappearing one by one

I am getting pretty frustrated with the drive letters disappearing. After **(My name) ( (X:)** vanished (together with the data) and I was unable to map the drive I did a total restore to factory settings. Starting the MyCloud 2TB up again the **X:** drive was still missing.What was left was: TimeMachineBackup ( (V:)
SmartWare ( (W:) and Public ( (Z:).

Trying the Map network drives in Windows Explorer the Z: drive disappeared!

I also get

The drive letters are visible on


I have sifted through other posts prior to postings this and see that I’m not alone with this problem.

Please advice

Have you tried rebooting your router?


The drive letters don’t disappear, they are still in use and therefore cannot be used again.
What happens if you click in the drives that carry the red cross? The connection should be reestablished immediately.

cat0w: yep tried it - not working.

Joerg_A: Clicking the red crossed drives I’m prompted for a password that I never sat up.

When you map the drive are you also checking the box that says “Reconnect at logon”? If not that might explain why the mapped drives keep disappearing.

1 Like

Yes Bennor “Reccoct at login” is checked.

Regarding your Windows File Exlporer: Yes and No; even using a public is combined with at least an anonymous authentication. Try to use your admin credentials you have set to log into the web UI. In the worst case you can type the username as

Domain\username like WDMyCloud\admin

This points the authentication process to use the internal admin on the My Cloud, not any other account. If you use admin without the leading domain, then Windows tries to look for an user account called admin within itself (on your PC). Sometimes these issues may occur. As @Bennor has shown in the dialogue, below “Reconnect at logon”, there is “Connect using different credentials”. If you tick this box, a new authentication dialogue appears where you can enter the above, full qualified WDMyCloud\admin as username.

BTW: WDMyCloud is generic here in this example. Of course, you have to use the real hostname of your own My Cloud device and the username that was used to login into the Web UI with adminstrative rights. Normally this user is admin but it may be anything else.

Thanks Joerg_A. Issue solved!! :blush:

1 Like