Drive keeps disappearing, can ping, no web, FTP, or SMB access

This drive has become very unreliable. I have the 2TB model. I have had it a few days under a year now. It seems like every firmware update makes it worse. Here is the latest thing I notice… I use the drive as a backup for my security camera. It appears that the drive just stops responding to anything but ping every few days. One camera uploads movie files and another uploads JPG files. There are thousands of jpeg files which may be causing the issue. I disabled the media indexing function a few months ago because the drive kept locking up, but now it freezes when I try to view the folder containing the thousands of files, or sometimes for no reason at all.  

The software is so messed up it thinks I updated to the last firmware before it was released:

Here is how often the drive locks up. Notice the missing folders correspoding to the missing dates: 

The drive is not full, it says it still has 200gb left. Has anyone came up with a fix to make this a “dumb” drive? I just need an FTP/SMB server. I don’t need time machine, DLNA, whatever else it is loaded with. I just need a share. Any ideas?



Have you tried this?

Of course, it will break your warranty etc…

Have you tried to disable the sleeping feature, to see if this changes anything? You can disable the DLNA server, iTunes server… in the panel

Happy xmas :slight_smile:

I finally fixed the issue by doing a couple things. I gotta give “alex” credit for this, I cannot find the post anymore but this fixed it. I turned on SSH and killed netatalk, wdmcserverd, and wdphotomerger by doing the following on firmware v04.01.02-417. 

(pull power cord, plug it back in so you can access it before it crashes again, turn on SSH)crontab -e(nano will open, scroll to the bottom and add these lines:)* * * * * date >>/DataVolume/shares/Public/date.txt 2>&1
@reboot /bin/sh /etc/init.d/netatalk stop
@reboot /bin/sh /etc/init.d/wdmcserverd stop
@reboot /bin/sh /etc/init.d/wdphotodbmerger stop(then do ctrl+o, hit enter to confirm filename, then ctrl+x to close, then type "reboot" to reboot)

 It is sad that we have to do this for our devices to work. I have had uptime of over a day now when before it was not staying up more than an hour, I know this because of the:

* * * * * date >>/DataVolume/shares/Public/date.txt 2>&1

cron job that writes a text file every minute and prevents the drive from sleeping. 

I still get the issue where samba crashes but ssh does not crash anymore. So I simply run:

service samba restart

to restart the network share portion. WD should stick to hard drives and leave the embedded devices to synology or even netgear.