Drive fault, but tests come back clean

Came home yesterday and noticed a red LED on my MyCloud Mirror (Gen2). I logged in and the dashboard showed a drive fault; I checked the disk status page, and that showed drive 1 as bad (this drive is roughly a year old, and the device itself is roughly two years old).

I ran a full disk test overnight, and both disks passed; I ran a full scan disk, and both disks passed. I then rebooted to see if the error would clear (with both tests passing, assumed it was a dashboard error), and now I can’t access the dashboard at all.

Any ideas?

This is the second time I’ve had a critical drive error, without any prior warnings.

The device gets pretty limited use. I use it solely to backup my music collection, and very, very rarely actually listen to music off of it. I merely copy my music to it, and use Google Play Music to upload from the device to Google Play, and listen to all of my music from there. Having a drive failure a year, with such limited use, is rediculous given what this device is being sold as.