Drive directory not accessible

I purchased the Passport Port Ultra 1 TB drive early this year and am using WD Smartware Pro 2.4.14… The backup worked well until last night. After the backup, when I tried to open the Document directory on the drive, an error message indicated the directory is corrupted and unreadable. However, other directories that were not updated during last night’s backup were accessible. Quick drive test passed. Please advise on how to solve the problem. Thanks.


Can you copy said folder from your unit into your computer? Data corruption does not necessarily relate to a hardware failure, and as such a health test will likely pass. You’'ll need a data repair or data recovery software on this case.

Thanks for your reply. I don’t seem to be able to do anything with the corrupted Document folder. Can you let me know what data repair or data recovery software can I use? On the other hand, can I reformat the drive since I still have the files on my W10 PC. If I need to reformat the drive, where can I find information on reformatting the WD drive.

Very Best,