Drive completely destroys my network

OOps, sorry, I forgot Mac is more linux-y than PC-ish.

Correct command is 

ssh root@x.x.x.x

Gents,

I hope you don’t take my blaming the router as the culprit as “WD doesn’t care”. If it can be determined that the Duo is in fact doing something, we will fix it, but it is pretty hard to do in a forum. We test on a wide variety of models of routers. We have beta testers all over the world that test on their own routers. We use external certification organizations that do testing for us, so we are not totally clueless here :). Hopefully TonyPh12345 can help you identify the issue within your network. I will monitor this thread to see if anything specific points to us though!

Hello Tony,

That’s great to read you.

I really understand that this type of bug is diffcult to identify by a forum.

Fisrt thing I see on my network is that some DHCP request are sent by the NAS, but it was configured with static IP adress, routing port OK, and I can access to it from my computer.

If you want to have some traffic log, I can do this.

If you want to have distant access to check what you want, I’m totally open to all.

Just trying to find something.

I’m searching what is active on the debian server embedded in the NAS.

Is their a possibility that avahi-daemon may have something wrong in its configuration or uncompatible with some routers?

Because of when the NAS is connected in my network and when I try to surf on the web from my computer, the problem seems to come from something wrong with DNS.

Patrick,

I just dropped in on this string…

Could you describe your network?

Reading the first page of posting you said that you only plug in the MBLD when you need to access the data. Also, that you cannot access it from the web. Could you clarify this some?

Thanks.

Looking at the packets sent/rec on my MBLD over ~10 seconds here are my numbers.

1st :

RX Packets: 108806

TX packets: 47322

2nd

RX packets: 108876

TX packets: 47367

So yours is seeing more traffic, but not multiple times more…

I woke up way to early this morning and did some more poking around. I reset the static IP for the MBL and and increased the last value by 100. How or why this would make any difference I don’t know but the activity on the network seems to have dropped. I’ve left the MBL booted up and on line all day and my son says there have not been any issues.

On your Mac, execute the command ‘arp -a’. Please post the results.

here is the result:

wireless_broadband_router.home (192.168.1.1) at 0:26:b8:6e:ec:19 on en0 ifscope [ethernet]
wireless_broadband_router.home (192.168.1.1) at 0:26:b8:6e:ec:19 on en1 ifscope [ethernet]
new-host-2.home (192.168.1.7) at e4:ce:8f:e8:76:1d on en0 ifscope [ethernet]
new-host-2.home (192.168.1.7) at e4:ce:8f:e8:76:1d on en1 ifscope [ethernet]
appletv.home (192.168.1.12) at 70:56:81:c5:74:6f on en0 ifscope [ethernet]
appletv.home (192.168.1.12) at 70:56:81:c5:74:6f on en1 ifscope [ethernet]
pdxrockpix.home (192.168.1.110) at 0:90:a9:b7:f:ac on en0 ifscope [ethernet]
pdxrockpix.home (192.168.1.110) at 0:90:a9:b7:f:ac on en1 ifscope [ethernet]
waldronnas.home (192.168.1.115) at 0:d0:b8:d:77:21 on en0 ifscope [ethernet]
waldronnas.home (192.168.1.115) at 0:d0:b8:d:77:21 on en1 ifscope [ethernet]
? (192.168.1.255) at ff:ff:ff:ff:ff:ff on en0 ifscope [ethernet]
? (192.168.1.255) at ff:ff:ff:ff:ff:ff on en1 ifscope [ethernet]

here is the result of the other test:

pdxrockpix:~# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:90:a9:b7:0f:ac
inet addr:192.168.1.110 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::290:a9ff:feb7:fac/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2004062 errors:0 dropped:0 overruns:0 frame:0
TX packets:524274 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2384874916 (2.2 GiB) TX bytes:979950515 (934.5 MiB)
Interrupt:36

pdxrockpix:~# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:90:a9:b7:0f:ac
inet addr:192.168.1.110 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::290:a9ff:feb7:fac/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2004093 errors:0 dropped:0 overruns:0 frame:0
TX packets:524298 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2384880188 (2.2 GiB) TX bytes:979957555 (934.5 MiB)
Interrupt:36

right now things look pretty calm on the network. the MBL light is a steady green, flashing every once in a bit. i just hope it lasts. i’ve had runs of several days without major problems only to have it followed by several more days of constant headaches.

My network is :

router ----- switch ----- NAS

My television is connected on the switch (100Mb/1Gb)

WIFI is off during my tests

On the router (100Mb) are plugged :

  • my computer

  • my printer (by WIFI)

  • Blue ray player (by WIFI)

My router is a french box which is used to connect to the internet thrue a optical fiber converter (I have FFTH)

This router provide television and phone services.

When my NAS is connected, I can’t have access (or with lot of difficulties) to the internet (seems to be a DNS problem).

When my NAS is not connected on my network, no problem.

When my NAS is connected, I can read/write file on it from my computer, and I can watch video streamed by the NAS on my television, without problem.

I need an expert view :

somthing link with this post ?

http://avahi.org/wiki/AvahiAndUnicastDotLocal

RussW:  Do you have both your wired and WiFi interfaces active at the same time?

The WiFi on my Fios box is turned off. I use my Airport Extreme for my wireless network.

Well all good things come to an end. My son just called me. Nothing can connect to the Internet. I have him check the MBL, light is blinking away. He unplugs the network cable from the back and what do you know? Life is good again. Everything is working fine. I’m getting completely sick of this **bleep**.

After some long search in the web, it seems my router doesn’t support well IPV6 request.

So first question : is IPV6 activated on the NAS?

Second question : how can I desactivate in the NAS it without broking eveything?

RussW wrote:
The WiFi on my Fios box is turned off. I use my Airport Extreme for my wireless network.

    • *That’s not what I meant. From the ARP output, above, it appears that your MAC is connected via both wired and WiFi simultaneously. Every hardware address appears on both en0 and en1 adapters. That can create all kinds of issues. But I don’t know nearly enough about Mac to say for certain that’s what I’m seeing…

Nobody can asnwer to my question about IPV6???

I just want to try if it goes better after disabling it, and give the feedback in this forum

Up :smiley:

No idea from everybody how to disable IPV6 on the NAS?

Patrick, the NAS does have an ipv6 Link-Local address on the eth0 interface.

Almost *ALL* Linux, Windows and Mac boxes do.   There should be no reason this should cause any issues on your network.

NAS:

MyBookLive:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:90:a9:f6:05:f8
inet addr:10.0.0.15 Bcast:10.0.0.255 Mask:255.255.255.0
inet6 addr: fe80::290:a9ff:fef6:5f8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:80617729 errors:0 dropped:0 overruns:0 frame:0
TX packets:39624835 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3477467889 (3.2 GiB) TX bytes:1795424702 (1.6 GiB)
Interrupt:36

Windows:

C:\Users>ipconfig

Windows IP Configuration

Wireless LAN adapter Wireless Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : …
Link-local IPv6 Address . . . . . : fe80::11df:8c34:ef9f:a403%11

(etc)

Completely disabling V6 is actually rather complicated, because it requires interaction with the Kernel.


All router should support it, but my router is quite old (I may have a new one next year)

The linux kernel inside is version 2.4, and seems to have some bad support of IP V6

Also I read some post in the internet, that said my box has some bugs with IPV6.

Hi all,

I installed MBLD yesterday.  My configuration is:

router : Orange Livebox2 (produced by sagem for France Telecom, Spain release)) 

two computers wired to the internal router switch: windows vista and  ubuntu linux.

MBLD:  connected also to the internal router switch.

several devices connected wirelessly:  ipad, iphone, macbook air, windows xp laptop, popcornhour A-110, apple TV

After several minutes I observed the same problem ONLY with the wireless -connected devices: they couldn’t connect to the internet. (wired computers experienced no issue).  After troubleshooting the results are:

1*/  The problem comes from DNS. the router DHCP server assigns the router as DNS proxy-server. If you try to obtain an IP address via nslookup there is no answer from the router.  BUT you can ping any public internet address so the packet transmission seems to work fine.

WORKAROUND: configure public DNS servers instead of using the router as a proxy in every device (ask your ISP which to configure or check the configuration of your router).  This solves the inconveniences but doesn’t solve the cause of the problem.  --> this can help most of you until a better solution is found.

2*/ There is also another problem. This seems to be affecting the internal processes of the router. Access to the router configuration is very slow as if the CPU were busy. 

3*/ As Patrick comments in a previous message in this thread, I agree with the relationship of this issue with the m-DNS issue in avahi. But can’t access the OS in MBLD to try the workarounds posted in avahi.org (could someone give me a piece of an advice on this?)

4*/  After 24 hours working the router configuration access speed seems normal again but when I try to use the router as DNS proxy, the first answer is always a timeout (2seconds)., but the second try works well.  With MLBD disconnected everything works fine again.

-I hate when behaviour changes without apparent cause. Makes troubleshooting a **bleep** !!!–

I am NO expert, so,  if someone can confirm my observations or try to connect the  MBLD OS to check the m-DNS configuration it would be perfect.

THANKS !!