Drive Becomes Un-Accessible After short use

Just got a MyBook World Edition I, White Lights and after finally getting my network/router set up properly it seems that every night the drive will go into StandBy and not come out of it unless I perform a hard reboot. 

The last two nights I was in the process of transfering files to the Public Share folder using Windows Explorer and all of a sudden I get the message that the Drive is Not Accessible.  No longer able to ping it, unable to access the web manager.

Has anyone experienced this issue?

I’m running WinXP, SP3 and using a Linksys WRT54 wireless router.  Mybook is wired to the router, PC is wireless.

thanks

I’ve got the same problem here with 3 Mybook World Edition II drives…it’s strange becouse sometimes I can use them 10 hours non stop, the next moment it will only work for 30 minutes and after that only a reboot of the drive can fix my problem, I wonder how I can fix this…

What kind of router do you have?  I’m not sure if it is something with the drive itself or perhaps a setting on the router.

I use a linksys wrt160n and I have to say that I’ve never had any problems with it, works fine here in my home with 4 notebooks and 3 desktop computers so it’s not the first thing that comes to (my) mind…

It seems like the drive goes into powersave mode or something (is my best guess)

Looked into the settings that are avalible in the different menu’s but couldn’t find anything related to powersaving or whatever…

so ANY suggestions would be very welcome!

There is a setting I remember seeing for Power Saving, I was going to try it later today.  It was under the Advanced Mode, then I think System -> Advanced.  The same screen you can enable/disable the LEDs.

It seems kinda weird though in my opinion that you can’t have power saving on and still use the drive as normal.

you are right! going to try it and see if it helps, but I have to agree that it is strange that I cannot use it with all the options turned on (hope this helps!)

nope…problem still there… :cry:

I have had the same problem for months now. Sometimes it will go for days and sometimes it will be inaccessible in a quick manner after a hard reset. For some reason, it seems like the amount of time that it is accessible depends on how much you are accessing it. For example, if you are doing a lot of file transfers, it seems to occur more quickly. If you don’t access any files on it for some time, it seems to stay accessible.

The only difference for me is that I can actually ping the device when it gets in this state. The web GUI and SMB access is a NO GO. I’ve tried turning power saving off and the whole nine. No luck. I also tried getting support from WD and I never got anywhere. They kept asking me BS questions that didn’t have anything to do with the problem. I think they have a secretary pool troubleshooting these devices. Either way, I’m not impressed at all with this product, but I think it could be really great if it would just remain accessible.

I’m still wondering if there is some setting in the router that causes the drive to go “offline”.  I noticed tonight that it didn’t go into standby, windows just stopping recognizing it, the LED still displayed the normal gauge illumination.  The IP address was still in my routers client table but I could not ping it nor access the mapped drives.

Another thing I noticed was that rebooting the drive by using the power button doesn’t seem to reset it.  I wonder if rebooting the router while leaving the drive on will reset it.

The next thing I think I will try to is set a static IP address, maybe the router refreshes the dynamic IP address periodically and this throws off the drive.

might be worth a try, but I can still ping the wd, I am afraid that it might be something with the firmware that gives us this error, sadly the wd ppl are not responding… :cry:

(/pissed off mode on) kinda stupid I think, we trust them by buying wd hardware but no support… come on ppl, all I want is my shares to be avalible on my LAN, this can’t be too much to aks for right? I’m not even trying to do the other “tricks”  that these disk are supposed to do… (/pissed off mode off)

btw. the wd discovery tool cannot find the drives either…

Still working on a solution, but did notice something strange just now.  I have an xbox 360 connected to the same router and I can access the WD drive from the xbox dashboard and watch movies located on the WD, but still cannot access the WD drive from my laptop.  Maybe firewall/antivirus relate issue?

EDIT:  I just realized I was able to ping the drive from my laptop when I disconnected my work VPN connection.  I wasn’t able to ping the drive or my xbox so that lead me to believe it was something on my laptop.  Do you guys have any other types of connections enabled?  Is your PC wired to the router or wireless?  Are there any special mechanisms in place like a connection bridge or anything like that?

I’ll let you guys know if the drve stays visible overnight.

first of all, happy new year everyone! and the best wishes! (don’t know about you guys, but I am in the netherlands and it’s 2:15 here now)

Next: there is no firewall in place in my LAN, my WAN sure, but I do not use one in my LAN, I cannot connect with my wireless or my wired network, so this (I think) cannot be an issue… but indeed strange that your xbox still can use the wd…

Maybe it’s using the mediastream function instead of the samba protocol?

I’ve been having mine running for months without a problem, and it gets pretty heavy use. The problem you’re describing almost sounds like a heat problem; it acts up under heavy use, when the drive will be hotter. Do the logs (Advanced Mode -> Status -> System Logs) show anything that looks like an error? You might need to go to the settings and increase the number of lines it shows.

It’s also a long shot, but are you running the latest firmware?

could be heat indeed, must say that I think it does get pretty hot, just cleared the logfiles and expanded it to 100 lines, let’s see what happens…I’ll post them here once I have some!

And of course, thanks everybody for the suggestions…

I finally got in touch with WD support via phone about this issue. I spoke to Tier 1 first, described everything I did and he immediately sent me to Tier 2. So, I described the issue and everything I had done per my previous post and he put me on hold for a bit. He came back and asked that I try and set a static IP on the two WD network drives I have because he said that they have observed that when it’s set for DHCP, sometimes DHCP transactions don’t go down as expected on the WD. I didn’t get into what fails with DHCP on the call because I already had both of my network drives already setup with static IP addresses. So then he put me on hold again for a while. He came back and stated that they hadn’t seen this issue. He suggested that I offload all of my data temporarily and then do a default restore onto the device and let them know if it occurs again after that. I’ve done this so far on one of them and I’m working on the second one at the moment.

As a tip for you guys, if you don’t want to look in that tiny window for system logs. You can simply do the following:

  1. Enable SSH access.

  2. SSH to the device and login with root/welc0me.

  3. Issue the command “tail -f /var/log/messages” without the quotes.

This will print out messages from the system logs as they happen to your SSH session. Personally, I’m hoping that something gets logged when it dies.

As far as the previous comments about heat go, my environment is temperature controlled and the devices don’t seem to be hot to the touch at all. However, I’m not sure if there is a way to read the internal temp. I’ll try to dig around, but I doubt it.

On this thread, it seems like there are two distinct issues going on here.

  1. Those that just lose Web GUI and Windows share access, but can still ping the device.

  2. Those that lose network connectivity all together.

All of my comments pertain to issue 1.

Thanks

Happy new years to you all as well.

Well, after realizing that my VPN connection was throwing off the mapping, I have been using the drive pretty continuously for the last 24 hours with no problems, so I think for my specific situation, the VPN was the problem.

lonestarshack wrote:

 

As a tip for you guys, if you don’t want to look in that tiny window for system logs. You can simply do the following:

 

  1. Enable SSH access.
  1. SSH to the device and login with root/welc0me.
  1. Issue the command “tail -f /var/log/messages” without the quotes.

 

This will print out messages from the system logs as they happen to your SSH session. Personally, I’m hoping that something gets logged when it dies.

 

The only problem I can see with that is that if you lose network connectivity, you’ll lose the SSH session as well and won’t see the logs. :slight_smile:

If that does happen, though, you should be able to restart the NAS, reconnect through SSH, and use vi instead of tail to view the logs.

Even in a temperature controlled environment, the drive can still get hot. It shouldn’t be a problem, but if a sensor is mis-reading the internal temperature, it might be shutting itself down.

There are still a couple of things I can think of trying.

  1. Since you have two, the next time you lose the connection and can’t ping the drive, go into an SSH session on the second drive and try to ping it from there. If that works, it points to a problem on your computer or network.

  2. Make sure you have the latest firmware. It’s probably not the problem, but you never know.

Understood, but the main reason I wanted to tail the output of /var/log/messages is so that I could see the last few lines before it dies and I possibly end up losing my SSH session. Then, after I end up getting the device back online I can issue “cat /var/log/messages” and hopefully find that last point and see if anything is there that might help lead to the issue. 

As far as firmware, I am running the latest. 

It’s not my network. I have a very basic flat network, there are no duplicates, and the PC that I have connected with the SSH session is directly connected to the same switch that the WDs are hooked to. Just to be absolutely certain my switch wasn’t the issue, I have even swapped it out. Then, I inserted a hub, yes, a real hub, and I even have wireshark running on a ring buffer to see if any specific network traffic isn’t causing the issue. 

My guess is that something is potentially going on with one of the daemons; more specifically, smbd. I just restored my second WD to default and will let it run for a bit. If I don’t see it die in the next 24-48 hours, I’ll let the group know. I’ll also fire up my xbox360 and ps3 if and when it dies to see if I get the same results as the gent from the Netherlands. Also, I’ll try the afpd to see if that responds. If this is the case, then it might be even more conclusive proof that it is just smbd that it is dying. More details to come…

Oh ya, forgot to mention. As mentioned in my previous posts and other posts by other people, you can still ping the NAS when share and Web GUI access dies.

So far no problems here (anymore) I am finished transfering the massive amounts of data from my storage to the wd now, so there isn’t that much reading and writing the last 2 days, to my big suprise I woke up this morning and the drives were still avalible! :smiley:

Still I do not understand what the problem might be, sbm freezing up? too warm?? I will see what happens in the next couple of days to see if the problem is solved or not.