Drive acts funny


I have the 3TB drive (WDBACW0030HBK) that started acting weird since last week

I was copying some data from my girlfriend’s laptop to the drive when it popped a text box indicating some kind of “delayed” data transfer error, and then it stopped receving any data the laptop sent thronwing a driver reading error

I removed the drive from the laptop and plugged it into my pc and it wasn’t recognized, the pc makes the “plug-in” sound everytime you connect an usb device, it tries to install the drivers but ends in an error saying they can’t be located

I tried installing the drivers the WD page has, but the drive only shows up in “Printers and other devices” as “My Book 1130” , it does not appear under my pc or in the Disk Manager (it only showed up once in the Disk Manager but i couldn’t modify anything, it didn’t let me saying the volume was not ready)

The disk only seems to work “fine” when I Unplug it and leave it like for 2-3 days and then connect it to the pc, it shows up fine, can access it, but it “dies” after a couple of minutes leaving me back to the start of the problems

Navigating throught Device Manager each time the drive is plugged it shows the WD SES Device USB Device with a yellow triangle under "Other devices and a IDE Controller also shows up with a yellow Triangle (AWYOICKZ in this case) 

This repeats on every pc/lap I’ve connected it to, is my driver dead? or should I try and format it when it shows up after the 3 day unplug?

Hi, that sounds like a data corruption problem, the PC is recognizing that you have the Ext HDD connected but is unable to read the files. If you don’t mind losing your data you can use the option to write zeros from Data Lifeguard Diagnostics. That will delete anything that you have on the HDD but then you should be able to reformat it from disk management. If that doesnt work you might need to replace the HDD.,209,316/session/L3RpbWUvMTMyNjU1Nzk1Ny9zaWQvS056MUk3T2s%3D

If the drive is recognized the something like TestDisk might restore it. Or some of the data recovery software some is free some try and buy there are some links in this post Maybe a Linux Live CD would work. Just download one and burn it and boot from that.


Thank you for your answers, out of desperation yesterday I Opened the drives case and plugged it in to see if the problem may be detected visually, the drive got detected instantly and started making “disk reading sounds” , I accessed it, tried to copy some stuff but it then stopped middle process and disconnected again to never appear under my PC again, during that, the drive started to make a repetitive “tick tick tick” sound, like if it entered an “infinite loop” and then died (still being recognized under devices and printers with a yellow triangle but not on my PC)

The recovery tools you mention wont even recognize the drive and I noticed that the drive doesn’t make the “reading disk” noise anymore anytime I plug it back in or turn it on after that

I’m checking now the disk manager section, and I have a 7th disk marked as “Unknown” that is not initialized

When I pick Initialize, after choosing either GPT or MBR it pops an error saying the drive is not ready,

I think the dive has a hardware failure, taking a look at the green board attached to the disk I see its like burned in some of the gray lines it has, specially more in the area where the led is you think that may be the cause it some times gets recognized and then it dies after a while

Thank you again for your answers, will be trying them for a while to see if i can have any luck with them, at least to try to recover some data