Dreded "Read Only" error...any fix

Seems like a few people have seen this issue.  I’ve had the drive for about a year (2 TB) and now it had this “Read Only” error.  I can see all of my data but I cannot copy it off the drive (this drive has all of my media, 1.5TB of it).  Trying to copy is painfully slow (XBench was something like 1.5Mbs) and I have tried to change the permissions in Terminal for the entire drive.

I’ve read that if I format the drive then use Disk Recovery tools (Stellar, Wondershare, etc.) I can recover the files but I did a simple experiment on a 250GB drive with a couple of folders on it, reformatted the drive and used the tool, it did not find the two folders on there so I am not taking that chance.

The drive has been working forever, it is HFS+ formatted.

Any one have any success getting the data off the drive or at least fixing this error?  I do not have a back up of this data (I have some but not all) and I really cannot lose my iPhoto libraries.



If you formatted the drive the data is probably gone. I don’t know about Mac so don’t know about recovery software. Did you try deleting the driver for the drive, disconnect it and then reboot system? When you reconnect the drive in Windows that will load a fresh driver.



I did not reformat the drive, I did that as a test on a seperate drive just to test out the format recovery tool.  It didnt work.

The drive is formatted as an HFS+ drive (Mac) and has worked for a while.  All of a sudden, it set iteself to “read only”

I can see all of the files but copying them to another drive is painstakenly slow, XBench had results of something like 1.5 which I think is like a floppy drive or slower.

Out of the 1.5 TB, I really need to get to about 500GB, the other stuff I dont mind losing but I am at a loss.  To copy one folder it said something like 81 days (pictures).  Folder is 145GB.


I don’t know much about Macs but it sounds like some type of corruption. There aren’t many Mac users here you might find more help at a Mac forum.