DOWNLOADER doesn't work with Ctorrent


#1

Hi, I use 1.5NAS (White led) with firmware 01.01.16.
When I access Downloader and put some CTorrent links, the download never starts.
Whereas in HTTP, all works fine.

I am considerring installing some 3rd party Torrent manager.

Any sollutions?


#2

I’ve seen it do that when there’s a tracker error. The CTorrent client isn’t very robust when it comes to handling problems. Are you able to start the torrents from a computer on the same network as the NAS (using a client that gives you better error information)?

Also, are you forwarding ports (TCP 2106 to 2706) to the NAS for CTorrent? If you’re not connectable and none of the peers in the swarm are connectable, you’ll never be able to start the torrent.


#3

Hi NAS-T,

I am able to start the same torrents on a PC connected to the sam AP by LAN using uTorrent.

TCP 2106 to 2706? Didn’t see it in any documentation. I will check it out


#4

Jacob wrote:

 

TCP 2106 to 2706? Didn’t see it in any documentation. I will check it out

 I don’t see it in the My Book World User manual, but the documentation for Enhanced CTorrent lists the ports:

http://www.rahul.net/dholmes/ctorrent/userguide.html#opt_download


#5

Opening ports helped!
Thanks.


#6

Hi guys I have just recently got a my book drive and cant get Ctorrent to work.  I have downloaded the latest firmware but when I add a torrent it lists the files and size of the torrent but when I click on peers it never shows anything and it never starts downloading but no errors.  I have a Dlink 2740b router and I have tried opening ports like you have suggested but still nothing.  Anyone any ideas or can you give detailed instructions so I can make sure I have done all necessary steps

Thanks in Advance


#7

I Ctorrent still doing broblems, all of them are speed related. My PC torrent is much faster than the Ctorrent.
I have no idea how to solve it so I am considering installing an external Torrent client. People with ‘World Blue Rings’ did that since the blue rings have no built in torrent client.
What I’ll figure that out I will post it here.

Cheers.


#8

I was having problems with the download until I noticed during an SSH session that I was getting errors with commands like “ping” and “wget.”–the domain names could not be resolved.  The device should be able to resolve hostnames, but alas it was not.  Here is what you need to do:

  1. Enable SSH:
    Login to the router via the web interface (this is the only way I know how to do it), and Click: Advanced Mode->Advanced->Enable SSH (note the password).

  2. SSH using an SSH client.  (google putty if you have a windows machine, Mac/Linux come with SSH clients).

ssh root@

You should see the root command prompt:  #

  1. While still in SSH, type the following line exactly, except replace IP with the ip address of your router*, hitting enter when you are done:

 echo nameserver IP >>/etc/resolv.conf

  1. While still in SSH, test using ping:  

ping -c 3 www.yahoo.com

  1. The last test should show 0% packet loss and the IP of yahoo.

  2. To leave SSH type “exit”

* if you can’t find your nameserver IPs you can use google’s public ones and add both lines:

echo nameserver 8.8.8.8 >>/etc/resolv.conf
echo nameserver 8.8.4.4 >>/etc/resolv.conf

hope this helps,

  • b

#9

Hi thanks for the reply I have tried doing as you have suggested but I keep getting access denied when I try to log into ssh root.  I have tried typing in welc0me as the password and everything else I can think of but still cannot get logged on


#10

Hi guys, a few days ago I bought myself a WD My Book World Edition 2 (2TB), and I cannot make ctorrent work. I put to download one file from a free torrent site and also from a registered one and both remained in ‘Connecting to tracker to start’.

I’ve tried everything from above posts, opening ports from my router, verifying through ssh if i have packet losses (and i don’t have), etc. Please, do you have any other idea that I might try? Are there any other settings that I must do (eventually in the advanced settings) that I don’t know about? Or, can you tell me how to verify directly from NAS how to verify on which ports ctorrent is going and if they are open? Or if you have any suggestion regarding this problem…

Thanks in advance.